Failed to load plugin url: …plugins/ajax-sea

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Failed to load plugin url: …plugins/ajax-sea

This topic contains 9 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #42111
    EditorCZ
    EditorCZ
    Participant

    After update to latest version I am getting this error in backend:

    Failed to load plugin url: https://green-gate.online/wp-content/plugins/ajax-search-pro/backend/tinymce/buttons.js

    #42112
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    When I tried to open the file, the server says that there is an issue with your .htaccess file, so it denies access to the file automatically.
    You can try reinstalling the plugin, to make sure the file was not deleted by accident, but this is more likely a server side problem.

    I strongly suggest checking the .htaccess file in the root and sub folder (if they exist), as well as the file access permissions. Direct access to javascript, image and CSS assets should be permitted on the server.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42113
    EditorCZ
    EditorCZ
    Participant

    Hello, thank you for your reply.

    Reinstall didn’t help.

    I attach screen from the backend with how it looks – the red column is the error, and you can also see that the Ajax content under the post is somehow broken.

    I will ask the hosting provider about it, but there was no change to .htaccess or file persmissions before the plugin update.

    Attachments:
    You must be logged in to view attached files.
    #42115
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Unfortunately this is unrelated to the plugin, the server does not allow access to that file. The file exists, as the error only states that based on a .htaccess rule it can’t allow loading the file, it denies permission.

    If the .htaccess was not changed, then it has a malformed mod_rewrite rule, which triggers for this specific path or path model. I strongly recommend reviewing the all of the rules, it is more than likely the source of the issue.
    Checking the file access permissions for accessing certain file types on the server configuration can also help, however this seems to be only affecting this specific structure, so it is much more likely a mod_rewrite rule problem.

    This file and it’s location was not changed for over 3 years.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42116
    EditorCZ
    EditorCZ
    Participant

    This is the only content of the .htaccess file in the root of the web:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I am not keen on the .htaccess rules and content so if you see anything wrong here, please tell me.

    HOWEVER when I rename the .htaccess to .htaccess.bak the problem presists.

    #42117
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    That looks okay at first sight, but make sure to check any sub-folders too, if there is any htaccess file upper in the hierarchy, it will override these rules.

    Then you will have to check on the server configuration. Try the tips from this topic, they were dealing with the same issue. Directory ownership and incorrect chmod can apparently cause the server not to be able to access the .htaccess file and then it denies direct access to some files.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42118
    EditorCZ
    EditorCZ
    Participant

    Just contacted hosting support – they advised to use their hosting tool to fix the files presmissions and voila – fixed.

    I believe this happened after downloading the plugin from the Evanto and uploading it manually to the server. To prevent this, what is the better way of updating the plugin?

    #42119
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Updating via the plugin manager is the best and safest way to update any plugin, as WordPress will extract and set the proper permissions and the file ownerships inherit from the apache server.

    Updating any plugin via FTP/SSH or other direct file upload methods is generally problematic as the client user ownership of the files are not neccessary in group with the apache server, so it may not be able to access the files afterwards. I only recommend that to developers who can set the ownerships and folder masks properly via SSH.

    You can also enable automatic updates, that is the same as updating via the plugin manager.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42120
    EditorCZ
    EditorCZ
    Participant

    Thank you for your support and information.

    Have a nice day.

    #42121
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    All the best to you 🙂

    If you don’t mind, I will close this topic soon and mark it as resolved, feel free to open another one if you have other questions or issues.

    If you like the plugin and have not rated already, feel free to leave a rating on your codecanyon downloads page and on the wordpress plugin repository, it’s greatly appreciated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.