Font styles not rendering correctly with multiple search boxes

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Font styles not rendering correctly with multiple search boxes

This topic contains 2 replies, has 2 voices, and was last updated by Bill Henderson Bill Henderson 5 years, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #9806
    Bill Henderson
    Bill Henderson
    Participant

    Hello – you can tell me your free Flywheel (www.getflywheel,com) account name and I can give you access to FTP that way, if you really need it.

    However my problem is that once you are logged in, if you go to https://www.forbiddendoctor.com/category/podcast/ page you will see I have created 3 search boxes. They work perfectly (LOVE your product, by the way) except for the font of the “Search Symptoms” and “Search Blog/Podcasts” text within the boxes. You can see the product search has a sans serif font like arial, perhaps, but the other two are using Times New Roman or something similar. All settings are identical – in fact I cloned the first box to create the other two. But for whatever reason, the style is not correctly applied on two of the boxes. Any idea what the problem could be here?

    Thank you

    #9807
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you very much for your kind words!

    From what I can see it seems that this might be a yet unknown bug, perhaps related to importing the options, I’m not sure yet.

    As a quick fix, I suggest using this custom CSS code:

    .ajaxsearchpro, .ajaxsearchpro * {
        font-family: "Open Sans" !important;
    }
    
    input.orig::-webkit-input-placeholder {
       font-family: "Open Sans" !important;
    }
     
    input.orig:-moz-placeholder { /* Firefox 18- */
       font-family: "Open Sans" !important;
    }
     
    input.orig::-moz-placeholder {  /* Firefox 19+ */
       font-family: "Open Sans" !important;
    }
     
    input.orig:-ms-input-placeholder { 
       font-family: "Open Sans" !important;
    }

    I will look more into this on my local environment, until then, this should hopefully do the trick for you.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9808
    Bill Henderson
    Bill Henderson
    Participant

    Awesome! Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.