Forums / Search in Content selector Default

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Forums / Search in Content selector Default

This topic contains 5 replies, has 2 voices, and was last updated by terriz terriz 5 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13551
    terriz
    terriz
    Participant

    1. This seems like a stupid question – but how can I add a post to the forum?

    2. Frontend Search Settings options > General I have “Show search in content selector?” set to On.

    But how can I set the default for that checkbox to unchecked? In the settings on that page it says “The default values of the checkboxes on the frontend are the values set above.” Above – where?

    I have looked all over, searched the forums and the knowledgebase, checked the documentation. If I set the “Show search in content selector” to Off, then it isn’t available to select at all.

    I’m sure I’m just missing it…

    Thanks,
    Terri Z

    #13552
    terriz
    terriz
    Participant

    1. Oh. “Open Support Ticket” = post to forum. Got it.

    #13580
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Terri,

    The state of those selectors (checked/unchecked) depends on the corresponding options on the General Options -> Sources panel.
    For example, for the Show search in content selector? is unchecked, if the Search in content? option is disabled by default: https://i.imgur.com/GaTrAvu.png

    I know it does not make sense, and it’s very inconvenient, my apologies for that. Most of these selector options were already re-worked (categories, tags, custom fields), these are schedule for the next release.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13588
    terriz
    terriz
    Participant

    Hi Ernest, thanks for the quick reply.

    Unfortunately, when I go to General Options > Sources, the only option below the “Search in custom post types” section is “Search in post (and CPT) IDs?”

    I don’t have settings there for Search in title / Search in content.

    I’m using 4.10.5.

    I’ve attached screenshots of what I am seeing.

    Attachments:
    You must be logged in to view attached files.
    #13591
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It’s because the ‘Index table engine’ is choosen, it automatically hides those options, as those are not used by the index table engine.

    The way to resolve it is to choose the ‘Regular engine’, then the ‘Search in content’ and the other options will re-appear, then when you configure them, just change it back to the ‘Index table engine’, and then save the options. Hopefully that should do the trick.

    I will make sure to implement a solution to the upcoming release as soon as possible, this is way too confusing – I completely forgot about the problems when using the index table engine.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13592
    terriz
    terriz
    Participant

    Hi Ernest,

    Unfortunately it didn’t work – the Search in content selector is still checked by default.. To be sure I understand your directions: go to General Options > Sources, select Regular Engine, configure the options at the bottom, change back to Index table engine, and THEN save? (I.e., don’t save in between any of those steps, just at the end?)

    And yes, it’s confusing lol! If I understand correctly, Frontend Search Setting > General sets what selectors will be shown, and General Options > Sources sets the default values?

    Also, “‘Index table engine’ is choosen, it automatically hides those options, as those are not used by the index table engine.” So even if I select some custom fields to be searched, because I’m using the index table engine, it won”t search those? Only title and content? Or??

    This isn’t a critical issue for me, just something I wanted to tweak. I can wait for the new version where it will be clearer.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.