Gateway Timeout on Homepage

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Gateway Timeout on Homepage

This topic contains 9 replies, has 2 voices, and was last updated by

 
Participant
1 year, 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29110

    Participant

    Hi there,

    I’ve recently started having a problem on my site and we’ve determined it has something to do with this plugin. When I make changes on the home page, it seems to update it fine and all but then just gets stuck. See my little blue progress bar? Goes about 1/4 of the way then stops until I get the Gateway timeout screen.

    I talked to my developer who ran some tests and then determined that it only happens when the Ajax Search Pro plugin is active. And it only seems to happen on the homepage, no other page?

    Can you help??

    #29111

    Participant

    here are the screen grabs

    Attachments:
    You must be logged in to view attached files.
    #29114

    Participant
    You cannot access this content.
    #29115

    Hi,

    Thank you for the details! I have tried to log-in to check, but I am getting the following error: https://i.imgur.com/zOMsrDH.png

    Error 504 usually means that there is either a firewall blocking a request, or the server cannot handle the request. If you have a lot of heavy duty plugins active, then it could very well cause this problem. I suggest disabling a few plugins (like 5 or more), to see if it changes anything – if so, then the server might be running out of either memory or processing power.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29116

    Participant
    You cannot access this content.
    #29119

    Participant
    You cannot access this content.
    #29127
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29166

    Participant
    You cannot access this content.
    #29174

    Hi,

    It is not the plugin actually – wordpress itself requires decent amount of memory alone, If you would disable 1 or 2 other random plugins, the problem would very likely go away as well. Just by disabling ours, probably a couple of kilobytes have freed up, and the application was just able to run on that page.
    You have a lot of plugins active, I would strongly recommend increasing the memory limit to up to 512M if possible – I would not recommend anything below that, as you have Page builders, Yoast seo, DB migration, security, ACF, just to name a few – and even though all of them are highly optimized, including ours, the memory consumption adds up quickly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29176

    Participant

    Got it, and thank you for taking a look. I’ve forwarded your comment on to my hosting provider and he’s agreed and said he would increase the memory should we need it.

    Thank you!!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.