https/ssl certificate problems, because of css files of yours

Home Forums Product Support Forums Ajax Search Pro for WordPress Support https/ssl certificate problems, because of css files of yours

This topic contains 14 replies, has 2 voices, and was last updated by

 
Keymaster
7 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1112

    Participant

    Hi,

    i installed you plugin and figured out, that it doesn’t support ssl. Please enable ssl in a future update.

    One very important thing. Some of your files aren’t automatically enabled with https, this crashes my sites ssl certificate.

    For example the pt.sans css file which directs to google web fonts hasn’t https linkage. Some of the others have.

    So i hope you can fix that issue. Thanks.

    Greetings,

    Sebastian

    #1113

    Hi!

    Thank you for noticing! Previous version were 100% compatible, but when developing new versions I sometimes forget to check the ssl compatible urls 🙂 Unfortunately I don’t have an ssl enabled test environment, but I will start fixing these now.

    Will get back to you as soon as I manage to fix these issues!

    Thanks,
    Ernest

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1114

    Hi!

    I’ve managed to enable ssl on my test environment, installed the search and fixed the bad css/script tags with “http” urls.

    I’m attaching the fixed version to this post, all you need to do is uninstall/reinstall the plugin, or overwrite the files via ftp (that’s better/safer).

    After overwriting, please open up each search instance you have created so far and save them again, to overwrite the existing css files, or to be sure you can delete them all and make new ones.

    Sorry for the inconvinience!

    Best,
    Ernest

    • This reply was modified 7 years, 10 months ago by  Ernest Marcinko. Reason: File added
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1115

    Participant

    Hi,

    thanks for that. Cant see the attachment!

    #1116

    Indeed, sorry. Just ported the site to a new template/wp version will fix this in a minute.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1121

    You should see the file now 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1127

    Participant

    Hi,

    i did as you mentioned above. There are still some files which are not in https:

    style 1 to 8.css

    Try to import google font PT SANS via http.

    Greetings,

    Sebastian

    #1128

    Participant

    Maybe you can check all css files and then send me an updated version again. Thanks for your help. Maybe it would be helpful for other users if you would upload the update to code canyon as well. Thanks

    #1129

    Participant

    The http/https problem occurs as well with your png and other graphic items. They are set to http as well!

    And the pictures of the search bar such as load and so on are located on your server. Maybe you should load them into the folder. Otherwise it will never function with https, because your server doesn’t support https!

    #1130

    Okay, it seems like this is because the css files are not writeable on your server, I’m 100% sure. The style1-8 css should be dynamically written when the search is saved. Those are the default values. Try to chmod the ajax-search-pro/css and the ajax-searhc-pro/cache folder AND all of its contents to 777 if possible.

    You can also enable the Force inline styles on the Compatibility options tab, it should solve the issue right away: https://i.imgur.com/K6uolR5.png

    • This reply was modified 7 years, 10 months ago by  Ernest Marcinko. Reason: image
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1134

    Participant

    In the zip. file you did send me the css files had http commands not https.

    So can’t use that files.

    I checked it. It had nothing to do the 777…

    On other information. The search bar is loading icons which are on your server. As long they are not in the plugin folder https won’t work.

    Greetings,

    Sebastian

    #1135

    Dear Sebastian!

    You can DELETE those files, because they are not loaded in the header. The reason you see the icons from my server, because the style1-8.css files are not writeable, and the default values are not changing when you save the search, trust me. The style1-8.css files are generated from the style.css.php when you save the corresponding search on the backend. It doesn’t matter what is in those files, they get overwritten if they are chmodded properly with your site url with the https tags and so.

    Once again, please enable the Force inline styles on the Compatibility options tab (https://i.imgur.com/K6uolR5.png) and you can delete the style1-8.css files from your server. This way the styles wont load from the unwriteable css files, but will load in an inline safe stylesheet, and all the icons/images/png and gifs will load from your server. That is the safest option for an ssl enabled website.

    Also if you have a cache plugin enabled, don’t forget to clear the cache after changing the search options.

    Here is the search with the deleted style.css files in case you don’t want to delete them manually from your server via ftp.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1138

    Participant

    Thanks, i checked that should work. If not i will get back to you!

    #1155

    Participant

    Hi one other thing. I implemented the search bar and it finds short codes on my site. Even your search bar short code. How can i disable that?

    Greetings

    Sebastian

    Attachments:
    You must be logged in to view attached files.
    #1159

    There is no option to disable shortcodes from content (unfortunately no filter is available in WordPress for that 🙁 )
    However, there are some things you can do:

    • Enable “Run shortcodes found in post content” on the “Advanced options tab”
    • or Exclude the posts or pages from the search, that has shortcodes: “Exclude Posts by ID’s (comma separated post ID-s)” on the “Advanced options” tab
    • or, probably the best solution is to change the description field from post content to post excerpt:

    Change post content.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.