I don't get the behaviour of custom field search

Home Forums Product Support Forums Ajax Search Pro for WordPress Support I don't get the behaviour of custom field search

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #44438

    Dear Team,

    I don’t get the point with custom field search.
    It seams to me, no matter what I do, the search shows all custom posts.

    What I want:
    I have a custom post type with some fields. I am interested in:
    and also I have tags.

    I expected, that if I check a Prozess and / or a Dokumententype Ajax search will only performed in the custom post with these where the prozess and Dokumententype is the same.

    Let’s say we have:

    1 CP:
    Title: “First Item”
    Dokumententype: “Prozessbeschreibung (PB)
    Prozess: “Marketing und Aquisition”
    Tags: gesystag, gogo

    2. CP:
    Title: “SecondItem”
    Dokumententype: “Prozessbeschreibung (PB)
    Prozess: “Marketing und Aquisition”
    Tags: gogo

    If I uncheck “All” for both, ASP opens the search result and shows me
    document-download (<— no idea, what this could be)
    First Item

    If I enter “gogo” and uncheck all, I get “gogo” as a result.
    Why is that? I have unchecked all Dokumententype and prozess

    The same if I select different Dokumententype and prozess ….

    I really hope, you get my point. It is a little bit difficult for me to explain ….

    Thank you,

    Ernest Marcinko
    Ernest Marcinko

    Hi Michael,

    Thank you for the details!

    The unwanted items in the search were from the taxonomy gresys_tag, which I disabled for you here. Those options are to return the taxonomy terms as results, and you don’t want that in your case.

    Now if you check the filters the items should be filtered correctly and the unwanted tags will no longer be displayed.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.