Incorrect domain after export/import

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Incorrect domain after export/import

This topic contains 2 replies, has 2 voices, and was last updated by dwl003 dwl003 3 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20829
    dwl003
    dwl003
    Participant

    Hi guys,

    I have been testing this for awhile on my test site1 and wanted to copy a search over to a different test site (both test sites are wamp-based running on localhost). Because of the many config elements involved, I exported the search using the export function then imported into the other site.

    The issue I am having is that when I perform a search on the 2nd test site, (“localhost/site2”) and select a resulting entry, it tries open a page on the 1st test site (i.e. localhost/site1). I tried to delete and recreate the index on the site2, but the behavior continues to be the same, i.e. the URL contains “localhost/site1” when selecting a resulting item.

    I realize that the license itself only is intended for a single live site, but is it not allowed to work with 2 wamp/localhost based test sites?

    Any help would be appreciated.

    Thanks

    Dennis

    • This topic was modified 3 years, 6 months ago by dwl003 dwl003.
    #20842
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Dennis,

    The export files does not actually contain any domain information, it is always relative to the root path (‘/’). Moreover they does not affect the search in any way. The result URLs are always requested via the get_permalink() call from the WordPress core. The index does not contain any URLs either, only the keywords. One exception is if you use the cache, make sure that is disabled/cleared and not copied from one site to the other. The instance export process does not copy that, only the options.

    The license stands indeed for one end product, but the plugin itself does not limit the functionality in any way. You can still install it on any number of sites without problems. You can use it on any number of local/remote test installations as well. Only the automatic update feature is bound to one domain (which can be changed), but the functionality is not. It is only a legal issue, we cannot limit the functionality in any way 🙂

    If the plugin cache is disabled, then the only possible explaination is, that somewhere on your local wordpress configuration the site URL is not set correctly. If you exproted one test site to the other, usually the wp_options database table carries the home URL from the first site. You can try forcing the correct URLs on the wp-config.php files, as well as searching the wp_options database for eny remains.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #20883
    dwl003
    dwl003
    Participant

    Hi Earnest,

    Thanks for you detailed reply – it is much appreciated. Whenever I copy a WP instance, I always use the Duplicator plugin which does a phenomenal job at converting every last domain reference correctly. Based on that I would guess that it may be the cache. I will experiment with disabling and clearing before exporting instances of the search.

    Interestingly, I later performed an export of the same search and imported it into the live site and that worked flawlessly.

    Thanks again,

    Dennis

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.