Index table engine is SLOW

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Index table engine is SLOW

This topic contains 5 replies, has 2 voices, and was last updated by kommunen kommunen 6 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6536
    kommunen
    kommunen
    Participant

    The index table engine is VERY slow. The regular engine is not fast – but ok.

    I thought it was supposed to be the other way around?

    Furthermore it can’t search for authors – even though a have turned this on in the index table engine.

    Hope you can help – and please notice that this is a live site.

    Best,
    Johan Seidenfaden

    #6537
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It was something with the caching. I went to the search caching options, cleared the cache, disabled the image cropping, now I’m getting 0.5 second responses, the performance tracker confirms as well: https://i.imgur.com/v4pxgBf.png

    It should respond in 0,5 – 2 seconds on the front-end, based on the amounts of plugins (32) active and the site load time (~9 seconds: http://tools.pingdom.com/fpt/#!/eOLKYn/http://www.kommunen.dk/ ).

    If you want to return authors (users) as results, you can enable it on the General Options -> User Search panel: https://i.imgur.com/LWsaxS7.png

    The index table only affects post, page and custom post type search. The author data there means that it indexes the author name, description to posts created by him, so looking for the author name should return his posts.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6540
    kommunen
    kommunen
    Participant

    Wow, that is what I call excellent support. Thanks! Not used to the problem actually being solved without me lifting a finger πŸ™‚

    And I see now that a search on the author actually brings up his articles. Only they are prioritized very low. Is there a way to prioritize hits on author higher?

    Again thank you!

    Cheers,
    Johan

    #6541
    kommunen
    kommunen
    Participant

    Ups, sorry maybe my enthusiasm was a little premature πŸ™‚

    The speed was fine BUT the index engine was not activated. When I activated the Index Engine the tempo dropped again πŸ™

    #6542
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think I know what the problem is, it’s actually a wordpress related bug as I found out.

    When using the index table engine, the Author of each post is parsed with a single query by using the get_users() wordpress core funtion. Turns out, there is something wrong with it and freezes for over 10 seconds. Someone else had a very similar issue, but I thought it was only his system affected.

    There are 2 things I can suggest for now:

    1. Use the regular engine until the next update. I’m working on it right now, and I’m definitely going to find another solution to the user related problem, so it’s going to be fixed.

    2. Disable displaying the author names on the Layout Options -> Results layout panel and still use the index table enigne.

    I’m sorry for this inconvenience, I didn’t know about this wordpress related issue before.

    Prioritizing the results by user is not implemented yet, it’s also coming with the next update. The relevance options panel will be extended a bit, where you will be able to set the priority for the author field as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6543
    kommunen
    kommunen
    Participant

    Beautifull! My enthusiasm is way back up πŸ™‚

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.