Isotope pagination not active till scroll down till see more

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Isotope pagination not active till scroll down till see more

This topic contains 5 replies, has 2 voices, and was last updated by

 
Keymaster
1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25979

    Participant

    Hey, I think I ran into this issue previously but if I remember correctly, this support system reset to a degree?

    Client asked to increase the amount of total results per page being output via isotope on initial load, from a search, or filter. I fiddled with every location I could find a total count, and total row output amount, and even wordpress’ blog output settings, for some reason I can’t get pagination to display without having to scroll to the bottom for “see more” to fire the ajax. I believe it has something to do with total numbers being output vs rows etc but I can’t get it to go.

    Something else I noticed. The “displaying 24 of 45” turns into “displaying 45 of 45” when I scroll down and activate the pagination, yet we’re still showing page 1, which is 24 of 45.

    I plan on using JS to move it, but you wouldn’t happen to have an option to move the “clear filters” button above the filter checkboxes vs below?

    Thanks again!

    #25981

    Hi,

    The initial number of results are set under the General Options -> Limits panel for the regular ajax search, and Layout Options -> Search box layout panel for the auto populate.
    The pagination triggers if the results number is lower than the (rows * colums) then the pagination does not trigger. You can either increase the limits, or change the rows count, or change the results width (that lowers the columns count).

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25984

    Participant

    Thank you. I guess I’ll set these to 999 for now and take a look at performance once data is loaded.

    I’m a little confused by the “displaying x results of x” I thought I’ve seen this display in the manor I’m expecting, but I don’t understand why page 1, which is 24 of 45, is saying displaying 45 of 45 when I up this limit enough to cause pagination. I have a feeling I see why it’s doing this with isotope but I’m not sure how to get this past the client when they point it out.

    Thanks again.

    #25991

    I think it’s the auto populate limit – it is probably set to 25 – and the plugin displays the potential numbers there(?).
    Make sure to change that udner the Layout Options -> Search box layout panel. Optimally, it should be the same or more as the general limit.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #26029

    Participant

    I tired all types of limit combos and couldn’t find anything that worked. I’m wondering if maybe I’ve altered the default output or if maybe there are other variables I might be able to use.

    Is it possible for it to say:
    on page 1
    “Displaying 1-24 of 5000”

    on page 2
    “Displaying 25-49 of 5000”

    etc?

    Thanks again

    #26030

    Hi,

    That is actually not possible, I see what you need now. The number of result shown there is the overall number of results on all pages displayed, not the current page results counter.
    The number increases when using the “load more” feature only.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.