Issue with WPML

This topic contains 13 replies, has 2 voices, and was last updated by Jie Jie 4 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #14892
    Jie
    Jie
    Participant

    Hi,

    Please check my thread before:

    Support for WCML

    Everything works fine until I switched the default language from English to Chinese recently.

    Now I find that the plugin doesn’t work when I put in any words (have indexed).

    How to set properly to make it work?

    Hope you can help, you can login with admin account and check the issue as I have enabled maintenance mode.

    Best

    Jie

    Attachments:
    You must be logged in to view attached files.
    #14898
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Jie,

    I’m not able to view the site, I’m getting redirected to this screen on every page: https://i.imgur.com/i2gijz0.jpg

    How can I access the back-end? I have tried every possible url (wp-admin, wp-login.php etc..) but everything redirects me to this url. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14901
    Jie
    Jie
    Participant
    You cannot access this content.
    #14903
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Unfortunately it’s redirecting me to the same page as before. I have tried many different browsers, a second PC, mobile nad iPad as well, all same results. Please check this video of Chrome and Firefox: https://youtu.be/TH0iVid8IFk

    There might be an IP restriction or a malformed .htaccess rule. Using a proxy gives the same error, so the problem is on the server side, you can test it on this proxy: https://hide.me/en/proxy
    Every URL goes to not found. I hope this helps though.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14935
    Jie
    Jie
    Participant
    You cannot access this content.
    #14938
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Jie,

    Can you please add temporary FTP details as well?

    I see you have updated the plugin, and I guess that the custom code previously added is not working anymore – as I have incorporated that to the latest release.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14940
    Jie
    Jie
    Participant
    You cannot access this content.
    #14944
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    It does not work as it seems, it logs in, but then it freezes and sends a ‘PORT command failed’ error.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14946
    Jie
    Jie
    Participant

    I think you can now login via FTP.

    I am using Cyberdunk FTP.

    #14947
    Jie
    Jie
    Participant
    You cannot access this content.
    #14948
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you, this is working now.

    Can you please tell me in which file can I find these custom codes? It’s not in the functions.php file, and I cannot find them. I want to disable them and make some tests.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14949
    Jie
    Jie
    Participant
    You cannot access this content.
    #14950
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    The issue was indeed the first custom code, it is no longer needed for version 4.11.5. I have deactivated it in that custom plugin file. On the back-end I have changed the advanced title field to this: https://i.imgur.com/2Ju8u4r.png

    It will display the price with currency, as well as it should respect WCML too. Make sure to clear your site cache, and the search should work now as before.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14952
    Jie
    Jie
    Participant

    Thanks! It works well!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.