Issues with second search form

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Issues with second search form

This topic contains 10 replies, has 2 voices, and was last updated by

 
Participant
6 years, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #6241

    Participant

    Second issue on the same page – http://skylarkdev.wpengine.com/collection/
    For now thing look pretty buggy, I can’t even start working since nothing really works – so I’s appreciate a little bit of help.

    1.
    inserting second form on the same page doesn’t work. I created the exact replica of the first search form (by replicating the form and inserted it into the second block with the black background, the one that says “Cras finibusnon sed
    magna varius fusce risus eros”
    As you see it is displayed in an crippled manner.
    I need to be able to use multuple forms on the same page.

    2. Another issue is that I can’t even modify the replicated form. Please go to Ajax search Pro, second form (named “Genre Search”) and go to Theme options. Try to use Theme Chooser to change the theme and then save it. It s not being saved at all. And (as mentioned in #1 it looks crippled on the page)

    See attached

    Please help, so far I see nothing but bugs that preventing me from actually dealing with the project that the modules was purchased for.

    Cheers.
    Elijah.

    Attachments:
    You must be logged in to view attached files.
    #6244

    Participant

    It just started working by itself,,, no need to troubleshoot it. Sorry, but have no idea what just happened….

    #6247

    Hi!

    I’m guessing it was either a site, CDN or browser cache issue, unrelated to the plugin. If you are using W3TC or any other page cache engine, make sure to empty the page cache and update the query string and reload the page with CTRL+F5 to empty the browser cache as well.

    The search instance dynamic CSS is generated to 1 file for much better performance. If the browser caches too aggresively the changes might not appear after saving at first refresh. Webkit browsers like chrome or safari have crazy strong cache engine on CSS files, so I usually refresh with CTRL+F5 multiple times just in case.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6273

    Participant

    Yep, it was a server cache issue. I use WP Engine for hosting/caching – but there i something really weird going on with your plugin. Sometimes the result is not showing up for hours. Sometimes you change the style and it not changes it. I;m really not comfortable with what’s going on. And yes, I’ve cleared the server cache at least 10 times, I did CTRL+F5 at least 10 times, I’ve even waited 10 hours and cleared the history in Chrome IE and FF – and still no result.
    I don’t really wanna be going through this every time I need a change to the form.

    I’m also a web developer, I’ve had some issues before wit caching, but not like this. It is defintely not only caching.
    11.jpg – hows how it is seen on the backend
    22.jpg – how it is displayed on the site

    And I swear, I’ve cleared everything 10 times and even waited 10 hours hoping it would go by itself. Not sure how can I keep working like this.

    Attachments:
    You must be logged in to view attached files.
    #6276

    Participant

    I did another round of total clearing…. nothing changes.
    I’m sorry, If it was up to me I would not pint my finger at chaching at this point.

    #6277

    I just logged in and checked the back-end settings.

    I see 3 instances on the front-end on the linked page. All 3 of them are with the search id “6”, which is the “Genre Search” you have created.

    Then I went to check the “Genre Search” on the back-end and it looks exactly like on the front-end. Then I opened the settings on the search with the ID “1”, “Portfolio Search” and it is indeed looking like the first screenshot, but this search is not used on the front-end at all. All 3 instances you have use the shortcode with the ID 6.

    Can you please check the shortcode on the second screenshot, it looks like it’s with the ID 6 and not 1.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6280

    Participant

    “Portfolio Search” and it is indeed looking like the first screenshot, but this search is not used on the front-end at all.”
    —- That;s the one I’m talking about. If it is not supposed to show up on the front end (I actually like he look) – then what’s the purpose of having it as an option in available styles? (I hope you would agree that i is confusing…)

    Thanks a lot
    Elijah.

    #6281

    I do not understand the problem at all right now.

    You have created 3 different search instances, but using only one of the shortcodes, with the ID of 6. The reason why the screenshot from the front-end is not looking like the one on the back-end is because those are two different search instances. One is number 6, the other is the 1.

    If you correct the shortcode, it will display the correct one. Right now the 6. is displayed 3 times because the shortcode of that instance is used.

    The reason why there were no changes on the front-end, is because you were styling instance number 1, and it’s not used on the front-end, only number 6. Therefore it’s not going to change ever, unless you correct the shortcode.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6282

    Participant

    Oh my god πŸ™‚ I value your time and support and (damn) I’m really sorry for this stupid mistake, I was working really late last night.

    I deal with clients myslef and I really hate when they consume my time for doing mistakes of their own. Sorry man.

    #6283

    No problem at all, don’t worry πŸ™‚

    We all make mistakes. A few days ago I was fixing something for 5 hours, when I realized one of the files in the editor (had like 25 opened) was from a different folder. I know the feeling πŸ™‚

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6284

    Participant

    We all have stories like this πŸ™‚ I was using once my medical card in banking machine trying to withdraw money.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.