Issues with sliders, centering and more

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Issues with sliders, centering and more

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 years, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #21356
    Kaalund
    Kaalund
    Participant

    Hello I have purchased the Ajax search pro plugin and have some technical difficulties which I could not find a solution for in the documentation.

    1. No matter which option I use for the results (hover or block) they seem to overlay my content on the page, so I cannot scroll. The results are on the screen, but do not move when I try to scroll. However I can see the rest of the page content scrolling down behind it – what could be the cause of this problem?

    2. I have gotten these sliders on my checkboxes which are not needed, nor wanted (see attached screenshot). How do i disable them?

    3. Is there a way to customise the location of the checkboxes? Not just the order, but how many of them you want per column and which ones you want in the same column?

    4. We are also having trouble with the shortcodes for putting settings elsewhere on the page. How do we use a shortcode for centering the checkboxes (settings)

    The url where the search pro is used is this: https://www.energizers.com/energizers/ you can see if you try and use it, that the search bar and results stay in the same position no matter what you do and if you scroll you are only scrolling down the content ”behind” the search function.

    Can you help?

    Thanks in advance,

    Mikkel

    Attachments:
    You must be logged in to view attached files.
    #21367
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    1. Can I take a look at this issue somewhere? I just tried the search on this page, but I am able to scroll without any problems there. I guess you might have switched the layouts, so the issue is no longer present(?).

    2. I think this is due to the filter boxes exceeding the default max-height value, so the scrollbar is triggered to be visible. I recommend two things here:
    I.) Changing the max-width of the filter boxes to ‘none’ here.
    II.) Turning off the scrollbar script, as you probably doesn’t need it whatsoever.
    These should get rid off those.

    3. Well, it depends on the order of the filters, as well as on the layout of the filter boxes and the column count.

    4. Centering them is only possible via custom CSS, the filters will automatically follow the page direction. For most cases, this custom CSS should do the trick:

    .asp_sb_1 {
        margin: 0 auto !important;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.