Item not found

This topic contains 9 replies, has 2 voices, and was last updated by Jimtowner Jimtowner 6 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #9458
    Jimtowner
    Jimtowner
    Participant

    Hi,

    I created a new post to test that it can be found in a search and it is not found. You can see the behavior at http://www.jamestownspeaks.org/jimflix/

    Look at the “Latest Reviews” the one called “Test to See this in a Search”.

    Search on any of the custom fields (the ones in blue) and the post is not found in the search. The items below it are found in a search.

    I thought maybe there needs to be time for the churn to run but it’s been at least 12 hours since I created the post.

    Can you please take a look and figure out what the issue is.

    Thanks.
    Steve

    #9459
    Jimtowner
    Jimtowner
    Participant
    You cannot access this content.
    #9460
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Steve,

    Can you please also provide temporary FTP and login details? The post might not be indexed, but I need to confirm this via checking the configuration and the code.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9461
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think I have figured out the problem.

    When the user submits the information via the form, the custom fields are not intedexed, because it appears they are not created at that time yet(?), only after the saving is finished I guess. This should not happen this way, but there is nothing I can do to change that.
    When I go to the posts admin, and save the post, it’s immediately indexed correctly, so it confirms my theory.

    The solution I come up with, is that I have disabled the indexing in the search code, when a new post is created and leave it up to the CRON task entirely. I’ve made a test post which is not indexed yet, but in roughly 20 minutes (when the cron task runs) it should be with all the custom fields.
    I will check back then, to see if it got indexed as I expet it to.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9462
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Good news, it appears that the test post have been indexed successfully. This solution appears to be correct 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9463
    Jimtowner
    Jimtowner
    Participant

    Hi Ernest, I did another test after yours and it also worked. Thanks again for your support.

    I’m curious about what you said–” I have disabled the indexing in the search code, when a new post is created and leave it up to the CRON task entirely.” Where is that code and is there any possibility that it could be overwritten with a plugin update?

    #9464
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the unbelievable review, I just read it!

    The change I made was namely in the
    wp-content\plugins\ajax-search-pro\includes\classes\actions\class-asp-indextable.php and
    \wp-content\plugins\ajax-search-pro\includes\classes\core\class-asp-actions.php
    files. You can archive them if you plan re-installing the plugin.

    Yes, a plugin update will actually overwrite the change, but I will add an option to the upcoming update to control this behavior, so you don’t have to worry about it. I’m already testing a possible solution.

    After the update, there will be a new option on the index table panel, which you will have to turn off once updating: https://i.imgur.com/rBQq4yF.png

    That is all you will have to do after the upcoming update is ready.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9465
    Jimtowner
    Jimtowner
    Participant

    You’re welcome.

    Will the new option default be the behavior that I have now or will I have to set the option?

    If I have to set it about when do you expect the update? (I’ll need to set myself a reminder so I remember to set it if that is necessary.

    #9466
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    The option will be enabled by default, you you will have to turn it off.

    There are 2 additional things I have to test before releasing + the time it gets approved, so I would say within 3 days definitely.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9467
    Jimtowner
    Jimtowner
    Participant

    Thanks. Will be looking for it.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.