jQuery error

This topic contains 7 replies, has 2 voices, and was last updated by

 
Participant
6 years, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6485

    Participant

    Im getting this error
    Uncaught TypeError: jQuery.easing[jQuery.easing.def] is not a functionjQuery.extend.swing @ jquery.easing.js?ver=4.5.3:46Za.run @ jquery.js?ver=1.11.3:5i @ jquery.js?ver=1.11.3:5m.fx.timer @ jquery.js?ver=1.11.3:5kb @ jquery.js?ver=1.11.3:5g @ jquery.js?ver=1.11.3:5m.extend.dequeue @ jquery.js?ver=1.11.3:4(anonymous function) @ jquery.js?ver=1.11.3:4m.extend.each @ jquery.js?ver=1.11.3:2m.fn.m.each @ jquery.js?ver=1.11.3:2m.fn.extend.queue @ jquery.js?ver=1.11.3:4m.fn.extend.animate @ jquery.js?ver=1.11.3:5methods.showIsotopicResults @ jquery.ajaxsearchpro.js?ver=4.5.3:1257methods.showResults @ jquery.ajaxsearchpro.js?ver=4.5.3:1000(anonymous function) @ jquery.ajaxsearchpro.js?ver=4.5.3:939j @ jquery.js?ver=1.11.3:2k.fireWith @ jquery.js?ver=1.11.3:2x @ jquery.js?ver=1.11.3:5b @ jquery.js?ver=1.11.3:5

    you can see it here
    http://manual.nohaliahq.wpengine.com/coreagle/rules-book/

    #6486

    Hi!

    Just checked the page, no error message in the console and the plugin is working: https://i.imgur.com/xOD1AF9.png

    Probably it’s only your browser or site cache.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6491

    Participant

    Im not entirely sure about this as Im still getting the error and on more than one browser.

    Also, after updating the plugin Im getting this other error.
    [Tue Oct 27 15:23:42 2015] [error] [client 109.151.122.189] WordPress database error Table ‘wp_nohaliahq.wp_11_icl_translations’ doesn’t exist for query \r\n\t\t\t\tSELECT language_code\r\n\t\t\t\tFROM wp_11_icl_translations\r\n\t\t\t\tWHERE\r\n\t\t\t\telement_type = ‘post_coreagle’ AND\r\n\t\t\t\telement_id = 25 /* From [manual.nohaliahq.wpengine.com/wp-admin/post.php] in [/nas/wp/www/cluster-10773/nohaliahq/wp-content/plugins/ajax-search-pro/includes/etc/indextable.class.php:909] */ made by edit_post, wp_update_post, wp_insert_post, do_action(‘save_post’), call_user_func_array, asp_update_index_table, asp_indexTable->indexDocument, asp_indexTable->insertTokensToDB, asp_indexTable->langcode_post_id, referer: http://manual.nohaliahq.wpengine.com/wp-admin/post.php?post=25&action=edit

    If I deactivate the plugin both errors disappear.

    #6492

    Participant

    The plugin is correctly working as you wrote. it just fires this errors.

    Also can you please make the posts with the links private? I dont have the option to do that.

    • This reply was modified 6 years, 2 months ago by  onir.
    #6494

    I can’t change the thread to private, you wouldn’t be able to see it (wordpress only lets editor and admins to see private posts).

    If you want to post sensitive information, upload it in a .txt file, that is only visible to me and you.

    I still cannot see any of these errors on the page. The second one seems to be different. Is that visible on a specific action, like post editing or publishing or something else?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6495

    Participant

    About the jquery error you are correct. I tried browsing with incognito and got that it was an extension of chrome to cause the error: PageXray

    About the second error of the table, it’s a default WPML table as seen here: https://wpml.org/documentation/support/wpml-tables/
    WPML’s tables – WPMLDevelopers might be interested in WPML’s database tables and how language information is connected to WordPress post types and taxonomies.
    “The table that holds the language and translation information is called icl_translations.”
    And the error is “WordPress database error Table ‘wp_nohaliahq.wp_11_icl_translations’ doesn’t exist for query”

    It doesnt look about something to worry about, but how do the plugin related to this?

    #6496

    I probably figured out the casue.

    The plugin is compatible with WPML plugin, and in the current version I made a few changes related to that. The error message is referring to a function which tries to get the post language if WPML plugin is activated. Apparently some weird error happens when checking for WPML availability.

    I have a possible fix, by adding one line of code to the plugin. Try opening the wp-content/plugins/ajax-search-pro/includes/etc./indextable.class.php file and go to line 657 (or close to it), where you should see this:

    $lang = $this->langcode_post_id( $the_post );

    change that line to these:

    
    
    $lang = "";
    if ( function_exists( 'wpml_get_language_information' ) )
        $lang = $this->langcode_post_id( $the_post );
    
    

    That should get rid off the error message.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6501

    Participant

    hi

    yes this solved the problem. thank you.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.