Layout issue with Related Posts Pro

Home Forums Product Support Forums Related Posts Pro for WordPress Support Layout issue with Related Posts Pro

This topic contains 8 replies, has 2 voices, and was last updated by

 
Participant
5 years, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2241

    Participant

    Dear Sir/Madame,

    I’m having some problems getting the layout to display properly. Rather than adopting the slider view everything seems to be dropping below each other, which is strange because the lite version worked perfectly (apart from the images not showing which is why i purchased the pro version and I’ve since discovered they work once you stop using timthumb for image creation).

    When i edit the themes i see the following error displayed above the theme selection area, but no errors on the plugin “Error Check” area.

    “Error saving the stylesheet, please check the permissions on the css folder or enable inline styles on the compatibility options!”

    As you expect I then tried turning on the “Load inline stylesheets” feature but the problem still exists.

    All i want is for the plugin to display with the same layout as the lite version but with the images brought in. If this isn’t resolved then I’m going to have to ask for a refund.

    I’ve attached a photo of the problem with inline styling turned on, turned off, the error i’m seeing with inline styling turned off and a picture of the general error screen.

    Feel free to call me anytime weekdays between 9-5pm (GMT)

    Best regards,
    Simon Thomas
    [email protected]

    #2242

    Dear Thomas!

    Can you please link me a page or post where the plugin is enabled? As I can’t see it anywhere I’m unable to tell where the problem might be. You can make a page and put the plugin shortcode inside of it so no other users will notice it, then just send me the url to that page.

    Based on your description this sounds like a javascript issue, but I can’t tell until I see it. The error message indicates that the stylesheet could not be saved because the plugin has no permission to its own folders. That’s probably the reason why the timthumb isn’t working as well. Yet it should work with inline styles.

    It is also possible that some other plugin is conflicting with the related posts pro, or there is a syntax error somewhere on the site – I really can’t tell.

    You should also try to switch the script sources on the compatibility options panel from “Minified scoped” to “Minified”: https://i.imgur.com/ywfdD7B.png
    I’m not sure if it will help, but it’s worth a try.

    If you could also provide temporary administrator and ftp access it would help me a lot, as identifying the problem is only the first step, but finding the source and the solution is much harder. I would run a line-to-line debugging on the related posts code if neccessary. You can do this by editing your initial post in this thread and filling out the proper fields. (it won’t be visible to the public, just me and you)

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2243

    Participant

    Thanks, turning on the “Minified” option has now resolved the layout. And the plugin is live on http://www.4g.co.uk/lg-g3-4g-phone/

    However, it’s obviously much better if we could resolve the issue to get the “timthumbs” working because i presume they reduce pageload times. And removing the error message so the plugin works as recommended can’t be a bad thing.

    What permissions should the folders have? I could get my server hosting company just to double check the permissions.

    We’d rather wait and see if you can spot the problem before creating temporary logins and word-press accounts.

    Best regards,
    Simon

    #2244

    Actually timthumb is a little bit more resource heavy, but there is not much of a difference – at least I couldn’t spot it. The non-timthumb version generates the images once, then loads them every time, so once an image is created it’s used all the time. Timthumb does almost the same but after the page load, so the rendering is delayed, but microrequests are made towards the server to check the cache. Anyways, the results are almost identical.

    But if you want to use timthumb anyways, then check the permissions on the plugins/related-posts-pro/includes/cache folder. The permission should be 777. Some servers however does not tolerate this level so you can also try 766 then 755 as well. If none of them works, then the problem is elsewhere, or the permissions are locked via SSH.

    Same thing for the plugins/related-posts-pro/cache/ (folder only) and plugins/related-posts-pro/css/ (folder and all of the contents!). After changing permissions on the css folder the error message should disappear after saving the settings regarding the “Error saving stylesheet…”.

    If the error does not disappear then you can still try to turn off the inline styles option, it may still work. (there is a tiny chance the the server reports different permission values to the script than it really is, and it triggers the message)

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2245

    Participant

    Okay thanks I’ll give that a go and if it doesn’t work I’ll come back to you.

    Best
    Simon

    #2250

    Participant

    My server host has now set the correct permissions and it’s resolved the CSS error message thanks.

    “I’ve set the folder plugins/related-posts-pro/cache/ to 777, and the folder and contents of plugins/related-posts-pro/css/ 777, as indicated by the comments.”

    However, I’m still not able to turn on the timthumb setting which is listed as highly recommended.

    The plugin can be viewed here and I’ve turned on timthumb for a time so the error can be seen.

    http://www.4g.co.uk/lg-g3-4g-phone/

    #2251

    Hi!

    The timthumb image url is giving me the following error:

    A TimThumb error has occured
    
    The following error(s) occured:
    Could not create the index.html file - to fix this create an empty file named index.html file in the cache directory.
    

    You can check it here: http://www.4g.co.uk/wp-content/plugins/related-posts-pro/includes/timthumb.php?ct=1&cc=FFFFFF&q=95&w=200&h=200&src=http%3A%2F%2Fwww.4g.co.uk%2Fwp-content%2Fuploads%2FLumia_930_4G_small.jpg

    I suppose that timthumb needs an index.html file in the cache folder. Please try to create one with 777 permissions in the plugins/related-posts-pro/includes/cache/ folder.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2252

    Also please check if the permissions on the plugins/related-posts-pro/includes/cache/ folder are indeed set to 777.

    Be aware that there are two cache folders!

    1. plugins/related-posts-pro/cache/
    2. plugins/related-posts-pro/includes/cache/

    Timthumb uses the second one, that’s where the index.html file should be placed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2253

    Participant

    Thanks for all your help.

    Everything is now working perfectly.

    And great work on the plugin it’s fantastic and i hope it will continue to be updated.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.