Listing intermittently loads too long and with too much white space

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Listing intermittently loads too long and with too much white space

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 8 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36267
    dandolino32
    dandolino32
    Participant

    Hello. Thank you for your help.
    Since the last Ajax Search Pro plugin update, the listing on the Rides page will intermittently show up with way too much white space and take too much time to load (see attached snapshot). It’s integrated into an elementor posts widget. I don’t have any of the css and jss performance features enabled with ajax search pro, and tried some of them to see if that will help, but nothing. Will you please help me. Here is a staging website and login credentials are included.
    https://scbbstaging.wpengine.com/rides/

    Here is an older version of the site before the update where this issue is not happening.
    https://devscbb.wpengine.com/rides

    Thank you in advance
    Dan

    • This topic was modified 8 months, 3 weeks ago by dandolino32 dandolino32.
    Attachments:
    You must be logged in to view attached files.
    #36281
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the details, it helps a lot.

    The “white space” issue is caused by a timing related problem. The auto populate of the search finishes faster than the Elementor module has time to load. So whenever the plugin tries to trigger the “refresh” on the elementor module, it does not exist yet. It does not happen to me on each page load, sometimes the browser is faster, and Elementor is loaded first.
    I believe the simplest solution would be to turn off the auto-populate feature, I dont see much difference in the initial output, so it should not cause any issues.

    The performance hit is something from the server side. Whenever you try to query a page on the staging server via a dynamically changing query arguments, it takes a lot of time to process. Try for example: https://scbbstaging.wpengine.com/rides/?yx=123456
    For the first time, it will take around 5 seconds, until it is cached.
    The same thing does not happen on the development server: https://devscbb.wpengine.com/rides/?yx=123456
    The initial query takes only around 1 second.
    The plugin is not initiated when you visit these URLs, so there is something else causing the delay. Maybe the staging environment only has more limited resources and simply takes a lot more time to respond. Other causes can be firewall (especially WAF or a plugin), or something with the .htaccess file etc..

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #36294
    dandolino32
    dandolino32
    Participant

    Hi Ernest,
    Thank you for your support. Disabling the auto-populate feature works like a charm, with no change to the functionality. Appreciate it.
    Cheers
    Dan

    #36297
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.