Loader and 'close' button position with disabled magnifier

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Loader and 'close' button position with disabled magnifier

This topic contains 5 replies, has 2 voices, and was last updated by

 
Participant
4 years, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #9111

    Participant

    Hey there.

    There’s a small problem with loader image and close button placement when magnifier is disabled.
    Basically, the screenshot explains it all.

    Any way to have those float ‘totally right’? 😉

    Attachments:
    You must be logged in to view attached files.
    #9170

    Hi!

    You are very helpful reporting all these issues back to me, I really appreciate it 🙂

    That is indeed another bug, if the magnifier is disabled, it should not be visible. As a temporary solution, use this custom CSS code:

    .promagnifier {
         display: none !important;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #9171

    Participant

    No prob 😉

    #11859

    Participant

    Ernest,

    A somewhat related small “bug”.
    There’s no option to style the close button, so it’ll always be round, black with white fill and shadow. Of course, I can target it with CSS and restyle it easily, but maybe something you’ll want to consider adding in plugin options 😉

    Cheers.

    #11872

    Indeed, will note this one as well 🙂

    In the meantime you can style it like so:

    .probox .proclose svg {
        background: #333333 !important; /* the bg color */
        fill: #ffffff !important; /* the cross X color */
        box-shadow: 0px 0px 0px 2px rgba(255,255,255,0.9) !important; /* the border width and color */
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11875

    Participant

    Absolutely, that’s what I did. With the only change – I needed to restyle this piece in a particular form only (I have several ASP forms).
    So my CSS ended up like this:

    
    #ajaxsearchpro4_1 > .probox > .proclose svg {
    // styling here
    }
    

    Thanks for your attention to this.

    Edit: no idea how to escape “>” in the code here 🙂 Those “>” should be “>”

    • This reply was modified 4 years, 11 months ago by  nazar.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.