Long loading of Ajax search

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Long loading of Ajax search

This topic contains 7 replies, has 2 voices, and was last updated by balvit89 balvit89 2 years, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #27670
    balvit89
    balvit89
    Participant

    Good Afternoon,
    After update I have long load of Ajax search pro.
    response from the server is about 20-25 sec.
    Can you find the problem and give advice how to fix it?

    #27671
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    If you have a larger number of products with lenghty contents, I would recommend using the Index Table engine. The tutorial in the link will explain everything about the configuration.
    It should greatly increase the performance, if the issue was related to the number of items.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27673
    balvit89
    balvit89
    Participant
    You cannot access this content.
    #27674
    balvit89
    balvit89
    Participant

    I tried Index Table engine – works really better, thank you!
    But now some sku are not searchable.
    Can you guide me please?

    #27680
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Make sure that the “_sku” custom field is selected under the index table configuration. After that, just re-create the index, and it should be all right.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27707
    balvit89
    balvit89
    Participant

    I did this. Normal products can be found by SKU, but I can’t find variable products by SKU.

    #27712
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Your main search bar (ID=1) does not have the “product_variation” post type selected: https://i.imgur.com/8lsqObM.png
    If you change that, it should work.
    I tried on the product filter search bar (ID=2), it worked fine, I tried the phrase “1720”: https://i.imgur.com/Gb7HD2q.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27719
    balvit89
    balvit89
    Participant

    Thank you!
    So much settings, maybe I missed it!
    Now it works!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.