Missing Search results

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 10 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #44899
    saggarfire
    saggarfire
    Participant

    Hey, i have the problem that there are search results missing.

    For example on the site /kamera, there are several PXW models of the sony cams, but only one is showing in the results.
    Is there anything i can do about it?

    And another question, is there any option to handle the “-” better? For example I type in:
    sony pxw fs7 – the result is not showing. I type in sony pxw-fs7 – its shown.

    I hope you understand what i mean.

    Thanks for your support in advance.

    Best regards
    Dennis

    #44911
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Dennis,

    Thank you for the details, it helps a lot!

    From what I can see on the kamera page, that is a singular page, and the cameras are not actually a separate post type or a product, they are just part of the same single page.

    To show the results individually, they should be available as separate post type object (maybe under the name Camera or similar). Searching a single page and dividing it to separate results is not possible to do in WordPress in any way unfortunately. Usually this is solved by creating a custom post type, then adding each camera individually and then they are shown on an archive page (like the blog page). This is good for many reasons, you can add different taxonomies, fields and images to each camera page.

    Regarding the “-” dash character issue – the same result is shown, only a different part of the post is highlighted. The “-” is handled and the “Kamera” post is found where this text is present.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.