Multible lines and API data in search…

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Multible lines and API data in search…

This topic contains 6 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #45913
    KBCS
    KBCS
    Participant

    Hi there,

    Hope you are doing well 🙂

    I have a couple of questions, on which you can hopefully help me…
    If you check the homepage of our website, there is now just 1 search-line in order and ideally I would like multiple fields there, but I am not sure how to get those:

    1 (over the complete width): search website
    2 (half of the width): a search based on a taxonomy (sire of the embryo)
    3 (the other half of the width): based on a taxonomy (sire of the dam)

    Next to the multiple search lines, I have a question regarding the general search (1).
    We have information by API integrated in the ads. Is it possible to “scan” this input as well in the keyword search?

    If this is a paid customization, I would love to hear your rates and the time this would cost. Since I am running on a short deadline….

    Thank you so much in advance!

    Kind regards,

    Kelly

    • This topic was modified 3 months, 2 weeks ago by KBCS KBCS.
    #45923
    KBCS
    KBCS
    Participant

    I added an image what I meant with multiple lines search… Hope this helps!

    Attachments:
    You must be logged in to view attached files.
    #45926
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I’m afraid that type of setup (mutliple search fields on single search) is not possible. You could however use taxonomy and custom field filters. The “Dropdown/select with search” filter type is very close to what you may want.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #45938
    KBCS
    KBCS
    Participant

    Thank you!
    I have, however, changed it with the custom field filter. In the preview it shows correct, but in live mode it’s not working. Any ideas?

    Furthermore, how about the API, is this possible to use in the keyword search?

    Best,

    Kelly

    Attachments:
    You must be logged in to view attached files.
    #45956
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Make sure to clear the site cache if it’s different from the front-end and the back-end, that will cause that.

    I’m afraid external APIs are not possible to use. I suggest fetching and storing that data locally (in a post type for example), and that will make it available for search plugins including ours.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #45971
    KBCS
    KBCS
    Participant

    Thank you!
    I have used the clear cache function within the plugin, however, the issue is still there..

    Do you have a quick guide or other ideas from how to fix this issue?

    Best,

    Kelly

    #45975
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    My apologies – you were right.

    I had to look up past issues, and this was a known problem, specifically with some filter types and layouts, which was already addressed for the next release.
    I have made a tiny change to the code so it should be okay now. This is already fixed in the upcming release so you don’t have to worry about that.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.