Multiple Taxonomy Logic with checkboxes

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Multiple Taxonomy Logic with checkboxes

This topic contains 5 replies, has 2 voices, and was last updated by  Anonymous 11 months, 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #34908

    Anonymous

    I have custom post types under custom taxonomies. As seen in the screenshot “custom-terms.png”, I have custom posts with multiple “Height” terms attached to them.

    If you go to my test page https://staging20.beachboardwalk.vrdv.co/test2/ and check the following filters:
    Thrill Rides
    44″-48″
    49″ and Taller

    you’ll see some results. However, if you uncheck 49″ and Taller filter, no results show up, even though there are custom posts with both of these heights attached to them:
    44″-48″
    49″ and Taller

    How can I get the Heights filter to show any post type that has at least one of the Height terms attached to it instead of requiring ALL of the terms attached to it?

    Thank you.

    #34920
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    You are looking for this option here: https://i.imgur.com/Y7W8VBO.png

    That should resolve the issue 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34940

    Anonymous

    Thank you, but unfortunately that doesn’t work. I configured it as you show and now any filter I choose (without entering a search term) doesn’t do anything as you can see here: https://staging20.beachboardwalk.vrdv.co/test2/

    In fact, it even gives wrong results if I do a search for “Wipeout” (which only belongs to the 44″-48″ and 49″ and Taller categories) and choose Under 34″ as you can see in the screenshot.

    #34944
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    All right. I logged in to check the configuration and found the conflict. You have hard-inclusions set under the Advanced options panel. These will be in effect regardless of the filter states. I recommend clearing all of these inclusions (or only keeping the ones, which does not relate to the filter items): https://i.imgur.com/nJNFkWl.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34952

    Anonymous

    Strange, I didn’t add those… must be automatically added when I choose terms. Anyways, with a few other setting changes, it now works as I need it.

    Thank you!

    #34953

    Anonymous

    In case others want to know, see attached screenshot with my Frontend Search Settings > Advanced panel settings.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.