"No results! Did you mean:" Deactivate

Home Forums Product Support Forums Ajax Search Pro for WordPress Support "No results! Did you mean:" Deactivate

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
7 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1855

    Participant

    Hi,

    How can I deactivate the random words which are suggested when no results are found. For example, when I type “type”, it returns “No results! Did you mean:” and then a series of words which have nothing to do with our service/product.

    Can I either modify this list of words or just deactivate this function?

    Also, I have a post about “account types” and would like for the search function to return a result when the user writes “types” or “type”. So far, if I enter “type” it says “no results”.

    Thank you for your help,
    Celine

    #1856

    Hi!

    Those are keywords suggested by a google service based on the search keyword. You can turn them off on the General options panel by disabling the “Keyword suggestions on no results” option: https://i.imgur.com/UqhipcU.png

    Usually some words are treated by the database as “stop words” (or common words) when using Fulltext search mode. Most likely “type” is one of those words, so it’s ignored.
    To quickly solve this issue I suggest to turn off the “Use fulltext search when possible” on the fulltext search settings panel: https://i.imgur.com/eVQCtmB.png
    This wont affect the search speed unless you have a huge database.

    Don’t forget to turn off (if you have it on) or delete the cache after you change these settings. https://i.imgur.com/XXfJetc.png

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.