No Results when opening Search Results in a new page.

Home Forums Product Support Forums Ajax Search Pro for WordPress Support No Results when opening Search Results in a new page.

This topic contains 11 replies, has 2 voices, and was last updated by  Ernest Marcinko 1 year, 1 month ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #14808

    cojones
    Participant

    I have looked online and tried to fix this issue myself over the last couple of days and cannot find the issue.

    I get the search results that I want in the auto-suggest drop-down. I have set up my search results to open up on a new page, however when I hit “enter” to open the search results on the new page…I get no results. And I can't figure out why.

    Please help. I've lost a few days by trying to figure this out on my own. I think it may be something minor.

    When you attempt to login to my site…you will be asked for a passcode. Please let me know when you receive this request so that I can send over the passcode. Emailing me at [email protected] would be the quickest method to alerting me.

    Thank you in advance for your prompt attention in this matter.

    #14811

    Ernest Marcinko
    Keymaster

    Hi!

    Can you please check the back-end log-in details? I'm not able to log in to check your configuration on the /wp-admin/ page. I'm getting an incorrect password notification.
    My guess about the issue is there might be custom search query built into the theme itself, which basically overrides the results sent by ajax search pro to that page. I will have to se the configuration and the files too to be able to confirm. If that's the case, I will take a look if there is any way I can disable that override in the theme files. Sometimes it's possible, let's hope it is the case here as well.

    A passcode was not required though, it let me see the site without it.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14818

    cojones
    Participant
    You cannot access this content.
    #14826

    cojones
    Participant
    You cannot access this content.
    #14827

    Ernest Marcinko
    Keymaster

    Thanks!

    The theme is perfectly fine, the issue is something else. I have found that the search results page is completely replaced by a plugin, possibly the BuddyPress Global Search, but I'm not sure. The source of the page looks like it is replaced with buddypress related elements, and I assume it might be that plugin. If I'm right, then it is probably a separate search engine as well, so it displays it's own results, which are not affected by Ajax Search Pro.

    I suggest trying turning off that plugin, I'm almost positive it will restore the original theme search results page, and the ajax search pro override should work there as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14828

    cojones
    Participant

    Thank you. I deactivated it but still no luck.

    I've attached an example of the difference between drop-down results vs. new page search results using the same exact search terms.

    #14830

    Ernest Marcinko
    Keymaster

    Hi,

    The plugin is still active, as the back-end shows: https://i.imgur.com/bmmqNVQ.png
    You might have to de-activate it locally, or on the main network site.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14831

    cojones
    Participant

    Please disregard. You were correct. I actually deactivated the network activation but didn't deactivate the plug-in on the sub-site where buddypress is actually being used.

    #14832

    cojones
    Participant

    Ok. So I did deactivate locally but the problem persists.

    Also – can you please remove the images

    #14835

    Ernest Marcinko
    Keymaster

    I've deleted the images.

    I have de-activated on the back-end, with the log-in you gave me, and it works for me:
    – before de-activation plugin screen: https://i.imgur.com/nHlwBqt.png
    – after de-activation plugin screen: https://i.imgur.com/tKV9n2d.png
    – live results: https://i.imgur.com/t81uDSt.png
    – results page: https://i.imgur.com/HZe9LOS.png

    I left it currently de-activated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14836

    cojones
    Participant

    Ok. Working now for me as well.

    Thank you once again for your prompt and great service! You can close this ticket

    #14837

    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘No Results when opening Search Results in a new page.’ is closed to new replies.