No typing when clicking on search bar

Home Forums Product Support Forums Ajax Search Pro for WordPress Support No typing when clicking on search bar

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #34102

    Hi,

    I had to disable the plugin for now on my menu because I saw you are offline for the weekend and I can’t leave it up for that long broken. I am hoping there is not just a setting I am missing.

    I have the search bar in my menu and when you click it to start typing nothing happens and it will not allow you to type. I see in the demo preview it looks great but not in the live version on my actual website. I provided admin access so you are able to activate/enable the plugin whenever. If there is any additional information you need please let me know.

    Also, is there a tutorial or instructions on how to make my results page look like the attached image instead of the default posts layout that is coming up now?

    Thank you for your help.
    Sydnee

    Attachments:
    You must be logged in to view attached files.
    #34111
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the details! I have logged in and enabled the search to see what exactly is going on.

    It appears that the menu script has an event listener attached to all element within the menu, which does a blur event (I assume it is for mobile devices), and it coincidentally causes the issue as well.

    Luckily I think there is a way to get around it with a small custom code snippet, without disturbing the rest of the menu.

    Try adding this code to the functions.php file in your theme/child theme directory – make sure to have a full server back-up first for safety. For more details you can check the safe coding guidelines.

    add_action("wp_footer", "wp_footer_add_asp_script", 9999);
    function wp_footer_add_asp_script() {
    	?>
    	<script>
    	document.querySelectorAll('input.orig').forEach(function(el) {
    		el.addEventListener('click', function(e){
    			e.stopPropagation();
    		});
    	});
    	</script>
    	<?php
    }

    I also noticed some custom margin/padding added via the menu styling to the search input. To negate that, use this custom CSS:

    .asp_w>a {
        margin: 0 !important;
        padding: 0 !important;
    }

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34131
    You cannot access this content.
    #34137
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Use this custom CSS:

    li.menu-item-object-custom {
        line-height: 95px;
    }
    
    .asp_m_3 {
        display: inline-block !important;
        vertical-align: middle;
    }

    The vertical height is not correct on the menu wrapper either, but this custom CSS should resolve that too.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.