Not displaying at all with Event Manager and BuddyBoss.

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Not displaying at all with Event Manager and BuddyBoss.

This topic contains 9 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 5 years, 7 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #10927
    jrwstevenson
    jrwstevenson
    Participant

    Hi Earnest,

    I am using your plugin on my site along with the plugin Events Manager & the theme Buddyboss Boss.

    I am unable to display your plugin at all when using a combination of Events Manager and Buddyboss. If I deactivate Events Manager or change the theme, Ajax search Pro appears and functions correctly.

    An interesting note, I can use and display Ajax Search Lite without any issue.

    I am currently testing on a dev site that holds no valuable data. Please feel free to modify as needed.

    Thank you
    James

    #10951
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I’ve tried to log-in via FTP to maybe enable debug mode to see if there are any error messages there, but I’m seeing an empty directory only. Do I need to use any specific configuration for FTP access?

    I’m suspecting that some kind of conflict between the theme and the two plugins is causing the problem, perhaps a function re-declaration or something similar.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10952
    jrwstevenson
    jrwstevenson
    Participant

    Hi Ernest,

    Thank you for replying.

    I’m using WinSCP as my FTP client and the access credentials I provided you seem to work OK my end. The setting I’m using are as follows:
    Protocol: FTP (port 21)
    Encryption: None
    I have unchecked Passive mode in Advanced Setting > Connection. This would be my best guess to why you’re unable to connect. Apologies for not mentioning it before.

    Regards
    James

    #10953
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I’ve tried that already, but no luck. FTP, FTP(e)S, SFTP, active, passive modes, but everytime I get this error message:

    Could not retrieve directory listing
    Illegal PORT command

    I’ve downloaded WinSCP client, unchecked passive mode to see if that was the issue, but I could not connect either. Maybe there is a firewall, or I have to enter a directory to list?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10954
    jrwstevenson
    jrwstevenson
    Participant
    You cannot access this content.
    #10959
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    This was a tough one, but I have found the reason why it was happening. I will try to explain the best way I can.

    What I noticed that the search shortcodes were executed, but returned an empty string. I was first suspecting that something might be overriding them. I was correct, but it was not a 3rd party plugin, but ajax search pro itself. There is only a few situations when ajax search pro disables it’s own shortcodes – when a new post is created, updated and deleted, to avoid indexig it’s own shortcode contents.

    The way this is done, is that WordPress has “hooks” provided for these actions, so it’s very easy for a plugin to connect events for it. When creating and updating new posts, the “save_post” and the “wp_insert_post” hooks are activated. However in your case, when opening the front page, both of these hooks are triggered for some reason (this should not happen at all), which was causing the plugin to think that a post is just being created – causing further problems. I had to de-activate the indexing hooks for ajax search pro to fix this.

    However this does not fix the issue itself. Something (plugin or a theme) is causing the “save_post” and “wp_insert_post” hooks to trigger upon page view, which might cause more trouble in the future, as those are meant to be triggered by WordPress core only. Unfortunately there is no bypass solution I could implement for an upcoming update either to somehow detect this, as these hooks are meant to be used correctly, and it’s not possible to check if they run exactly when they should.

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10962
    jrwstevenson
    jrwstevenson
    Participant

    Hi Earnest,

    Whilst its not a “fix”, it does solve the problem I was having. Thank you. An excellent support service.

    I have made a copy of the modified plugin folder for safe keeping. May I ask how you de-activated the indexing hooks for ajax search pro in case I update or disaster strikes?

    F.Y.I. I thought the guys over at Events Manager would be interested in this topic. It may be something they can address. Here’s a link to the thread if it’s of interest to you.

    #10963
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You are very welcome!

    The change I made was to the following ajax search pro plugin file: wp-content\plugins\ajax-search-pro\includes\classes\core\class-asp-actions.php
    I have disabled the following lines (44-55):

    
                array(
                    "action" => "save_post",
                    "handler" => array("IndexTable", "update"),
                    "priority"    => 999999998,
                    "args"  => 3
                ),
                array(
                    "action" => "wp_insert_post",
                    "handler" => array("IndexTable", "update"),
                    "priority"    => 999999999,
                    "args"  => 3
                ),
    

    Thank you for opening a ticket with them as well, they might know better, and I’m curious if there is anything I’m doing wrong or not knowing.
    I will keep this ticket open in case something comes up 🙂

    Also, if you like the plugin, feel free to rate it on your codecanyon downloads page, it’s greatly appreciated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10990
    jrwstevenson
    jrwstevenson
    Participant

    Hi Ernest,

    I’m having a little CSS problem. If you could have a look at my homepage, you’ll notice that the check boxes aren’t appearing correctly. The design seem to be staggered horizontally, rather than stacked on top.

    I can easily add CSS in my themes options, I’m just not sure what to put?

    Thanks again.
    James

    Attachments:
    You must be logged in to view attached files.
    #10992
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi James,

    Yes, it appears to be a simple CSS conflict. Can you please try the following custom CSS, it should fix the problem:

    .option label:before {
        display: none !important;
    }
    
    .option label,
    .option label:after {
        left: 0 !important;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.