Not working on https

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6237
    James Scaggs
    James Scaggs
    Participant

    Hello,

    I have the plugin installed on my staging site without https and it works fine. My live site is an exact copy of the staging server but I have an SSL. It works fine on staging but doesn’t work on live site and I think it has something to do with HTTPS.

    LIVE SITE – https://harvillind.wpengine.com

    STAGING – http://harvillind.staging.wpengine.com

    Please advise.

    #6246
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Make sure you deactivate and activate the plugin to refresh the activation options. Transfering through to different protocols can be a pain with WordPress.

    Then open the search settings and save them, that will re-create the stylesheets with the https items.

    Some options may have been deleted through the transfer process, so I also recommend opening and saving the Cache settings and Compatibility settings submenus as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #7439
    James Scaggs
    James Scaggs
    Participant

    It’s still not working for me b/c of the https issue. What else can I do?

    #7441
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    1. Make sure to have the latest plugin version installed (4.7.0)
    2. Make sure to follow the safe update guide: https://wpdreams.gitbooks.io/ajax-search-pro-documentation/content/update_notes.html
    3. Make sure that the site url is updated in your database, I can see multiple items with “http://” in your site source, unrelevant to the plugin:
    here: https://i.imgur.com/qQhYMbS.png
    and here: https://i.imgur.com/SmX1rDm.png

    The plugin is 100% https compatible. Make sure to follow the safe update steps and everything should be all right 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #7485
    James Scaggs
    James Scaggs
    Participant

    Thank you for the quick reply. I’ve pulled the error from the console and the server log for you to review here:

    Server Log
    http://screencast.com/t/j408wvbTAvSh

    Console
    http://screencast.com/t/xEUdyCE7

    Screenshot of search.php line 11
    http://screencast.com/t/RH1I61vhO3GJ

    I’m currently unable to update to the latest version because there is some other plugin conflict with the new version but I will address that later.

    The version isn’t causing my problem b/c I have the plugin working on http just not https.

    Can you help me further?

    #7501
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    We have a better chance solving the conflict issue once you update.

    If you can provide temporary back-end and FTP access, I’m sure I can help once the plugin is updated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Not working on https’ is closed to new replies.