Ordering stuck on "Date descending"

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ordering stuck on "Date descending"

This topic contains 4 replies, has 2 voices, and was last updated by Federico Federico 5 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11575
    Federico
    Federico
    Participant

    Hello.
    I’m experiencing some trouble with results ordering. I’ve been working with ACF Pro for quite a while and everything was ok, but all of a sudden the results are coming up in the wrong order.

    In the “Ordering” section I have:

    Primary result ordering: Title ascending
    Secondary result ordering: Title ascending

    But the results come up in “Date descending” order.

    Right now I’m using an Index Table, but if I try the regular engine nothing changes. The same happens if I enable/disable “relevance” (with the regular engine) and if I enable/disable “ajax handler”. The caching right now is off, but I need to use it later. It seems stuck on “Date descending”, no matter what I do. I didn’t install or update plugins in the last two weeks, so I really don’t think that’s the problem.
    Any idea?

    Another quick question: is the “more results” option supposed to work with isotopic results (along with pagination)?

    Thank you,

    Federico

    • This topic was modified 5 years, 5 months ago by Federico Federico.
    • This topic was modified 5 years, 5 months ago by Federico Federico.
    #11577
    Federico
    Federico
    Participant
    You cannot access this content.
    #11588
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I just checked, but the ordering seems to be okay on my end: https://i.imgur.com/lqAwdDT.png
    I’ve tried multiple words and options, but it’s always ordered correctly.

    The more results should work with isotopic, however it’s still in experiment state, especially with lots of results, so it can be buggy.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11589
    Federico
    Federico
    Participant

    Update:

    I managed to solve the problem, but I think there’s something I don’t understand. Basically, the problem presents only if I enable the option “latest results” in the section “Auto populate”. But since I’d like to use this option (not particularly important though), is there a method to always force a certain type of ordering (in my case: “name ascending”; there’s only one post type, so I don’t need relevance), indipendently of the options?
    Thanks!

    The question about “more results” in isotopic mode is still valid, though! I have a ton of posts and I’d like to reduce the limits in order to make the query faster, but in that case I’d need the option “more results”. If it’s not possible, it’s not a problem. Caching works very well.

    P.S. If you still need to take a look: the credentials I provided are not valid anymore since I need to present the project today between 16:00 and 19:00 GMT+1, but I can provide new ones later.

    As always, thank you very much for your support.

    Federico

    #11590
    Federico
    Federico
    Participant

    I’m sorry. It seems we wrote at the same time :).

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.