Page content not showing in search results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Page content not showing in search results

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 7 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #12248


    I’ve installed Ajax Search Pro on the above development website. It’s just a build and test site at the moment so doesn’t have any live content. I created some test pages and the search function does not appear to be searching the page content. It returns results for the title and any search tags that I’ve placed in the Ajax Search Pro section but nothing from the page content/text.

    Also when I look at the setup for searching custom fields there are no fields shown and when I turn on the ‘Search all custom fields?’ section the whole custom fields area greys out.

    I’m using the latest version of wordpress and Betheme.

    Thanks in advance.

    Ernest Marcinko
    Ernest Marcinko


    If the content is not searchable, it usually means it’s dynamically generated, and not directly stored in the database. For example using shortcodes only as content. For that, there is a secondary, index table engine, which was built for cases like this. It makes an index of keywords based on visible post content (if possible). Please check these documentation links:
    Index table introduction
    Configuring and Generating the index table

    The custom fields are printed by default, due to their possibly extremely large numbers. There is a search field above the custom fields option to look for custom fields:

    When clicking the Search all custom fields? option the area greys out to indicate that the option below is no longer effective, because all custom fields are used anyways – no matter which ones are selected.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.