Plugin conflict with Divi theme?

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Plugin conflict with Divi theme?

This topic contains 6 replies, has 2 voices, and was last updated by thebizpixie thebizpixie 2 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #39751
    thebizpixie
    thebizpixie
    Participant

    It looks like there is a conflict between Divi and Ajax Search Pro.

    What happens
    When I edit a page that uses the Divi Builder, a few things may happen:
    1. If there’s no search form on page, the page reloads (ie it loads, and then after Divi loads, it reloads)
    2. If there’s a Divi block that contains a search form shortcode, a new tab opens (sometimes more than once) with a preview URL like /learn/?preview_id=36031&preview_nonce=beb8b7cd20&_thumbnail_id=-1&preview=true
    AND the page save fails

    Testing
    If I turn off Ajax Search Pro, all of these unwanted behaviours stop. It also stops when I switch to the Twenty Twenty theme.
    I have thoroughly tested switching all of my plugins on and off, and this is the sole plugin that fixes the issues.

    It also happens if I use a text module vs a code module.

    The console does not show any immediately connected error messages, but you may be better able to recognise these.

    How to reproduce
    Feel free to test with these pages:

    Test Page 2 – A simple test page where saving works, but the page loads twice after saving (page reloads after Divi loads)
    /wp-admin/post.php?post=36031&action=edit
    Try simply loading this page and watch the reload. Disable the plugin and relaod the page to see it only load once.

    Knowledge Hub – A more complex Divi page with a search box where a second tab opens and updates fail, if the shortcode is added to the code module
    /wp-admin/post.php?post=36959&action=edit
    Add the search form shortcode [wd_asp id=1] to a text or code module and try to Update. Watch a second preview tab open and the save fail.

    Requests
    I’d really like to:
    1. Stop the editor window reloading on pages that don’t contain a search form
    2. Figure out why the moment I add my search form “[wd_asp id=1]” to the page, a preview window opens and the save fails, and stop this from happening

    NOTE: The password to view the site front end is sacs2022

    • This topic was modified 3 months, 1 week ago by thebizpixie .
    #39753
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you very much for the details, it helps us a lot!

    I have tried to log-in to the back-end, but it says, that the credentials are incorrect. Can you please check?
    I may also need (s)FTP access too, to be able to debug the code, to see what exactly causes the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39819
    thebizpixie
    thebizpixie
    Participant
    You cannot access this content.
    #39820
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you very much!

    I have uploaded a beta version of the latest release to test, and it seems that the problem is now resolved – at least I am not able to replicate them anymore.

    Can you please confirm?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39837
    thebizpixie
    thebizpixie
    Participant

    Yes, I have tested this on another similar page, and I was bale to to save my changes and view the modified page that included the search box, and no additional windows were opened during that process.

    So it looks like the issue has been fixed.

    I look forward to the official release so I can test it on my main dev site as well.

    Thanks for your help with this.

    #39846
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39962
    thebizpixie
    thebizpixie
    Participant

    Thank you.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.