Plugin messing up Menu Settings

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Plugin messing up Menu Settings

This topic contains 4 replies, has 2 voices, and was last updated by dfitt dfitt 7 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4367
    dfitt
    dfitt
    Participant

    Hello:

    We just recently noticed an issue that seems to be caused by your plugin. If you login and go to Appearance -> Menus, you will see that the page is rendering everything without a style. If I deactivate Ajax Search Pro, the problem goes away. This doesn’t happen with the Lite version. Please advise. Thanks.

    #4385
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve debugged through the code with the plugin editor. Somehow some search shortcode is executed on the menu page. I have no idea why, but something must be triggering it.

    However the shortcode handler tried to quit, as it detected it’s on an incorrect page. But there was a bug present in the search code, which cleared the screen content before quitting, that’s why the half was missing. I’ve corrected that, and of course I’m putting this fix to the upcoming version as well.

    Thank you for noticing me!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4412
    dfitt
    dfitt
    Participant

    Thanks for your reply, Ernest. I’ve noticed that the Menus page in WP seems to be OK now, so I guess whatever you did fixed it. I’m guessing you just updated some of your code for the plugin? Is that correct, or was there more to it? I just want to make sure I don’t mess up any fixes you’ve put in. Thanks again for your help.

    • This reply was modified 7 years, 4 months ago by dfitt dfitt.
    #4420
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    It was only the plugin code, nothing else 😉

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4434
    dfitt
    dfitt
    Participant

    OK, thanks again for your help.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.