Problem on indexing post

This topic contains 8 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 years, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14002
    Dezio
    Dezio
    Participant

    Hello,
    I’ve a problem on indexing a page like this:

    http://www.dezio.it/oli-essenziali/muschio-di-quercia/

    If you try ti find the words “muschio di quercia” the thumbnail with image and basic info not appers.
    If you try with “abete rosso” or “basilico sacro” (2 randoms) the plugin preload thumb and basic info without problems.
    I already deleted the cache and reindexing all without success.

    edit: I found the problem on < 2 word on the title name. “abete rosso” are 2 words, if I use “cedro della virginia” it don’t work, how can I fix it?

    • This topic was modified 4 years, 10 months ago by Dezio Dezio.
    Attachments:
    You must be logged in to view attached files.
    #14017
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the log-in details, I was able to find the causes of the problem:

    1. Main problem: Because you have priorities set and the results limit is 10, the plugin will always display the results in the priority order, and cut out the rest of the matching results: https://i.imgur.com/9dIPOZ6.png
    In your case ‘muschio di quercia’ matched a lot of results, but only the top 10 with the highest priorities was displayed.

    I highly recommend changing back all the priorities to the default value 100, otherwise this will affect the search results too much: https://i.imgur.com/l62x2nY.png

    2. I believe that this logic configuration might be better for your case: https://i.imgur.com/J2OyWJr.png
    Because if the Exact matches are enabled, then the index table is not used at all. I have made this change, but of course you can change it back if you want it to.

    3. The ordering options are probably set incorrectly, both values were ‘by date descending’: https://i.imgur.com/A3ZiPPO.png
    I do not recommend this when using the index table engine, as it may cause the results to be less relevant, I recommend this configuration: https://i.imgur.com/W8pYVDD.png

    If you change back the priorities to 100 on all items, you should start seeing much more relevant results in more relevant order.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14029
    Dezio
    Dezio
    Participant

    Hello Ernest,
    I need priorities like this:

    – First search on the “title name”
    – Second on tag name (i use it for the botanical name)
    – Third exclude “blog” post from results

    final show results from A to Z during search preview.
    I make changes like your post but it don’t show in order from a to z when I type “muschio di quercia”.
    I need the exact matches only, cause I would point on 2 factors, title name and tag name, with “suggestion” when user type on search bar.

    Regards
    Dezio

    • This reply was modified 4 years, 10 months ago by Dezio Dezio.
    • This reply was modified 4 years, 10 months ago by Dezio Dezio.
    • This reply was modified 4 years, 10 months ago by Dezio Dezio.
    • This reply was modified 4 years, 10 months ago by Dezio Dezio.
    #14048
    Dezio
    Dezio
    Participant

    Please give me an answer about what I said on previus post.

    Thanks

    #14064
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Dezio,

    If you set the priorities, then the relevance does not matter, as it’s considered higher as the relevance matching. Since the results count is lower than the potential results set, the results are ordered as the priority dictates – leading to cutting out more expectedly relevant results after.

    If you want A-Z ordering, but as relevant as possible, then exact matching is probably not the best option to use – as exact matching can occur in all of the selected fields.

    Based on your description I recommend the following configuration:
    1. Very important: Resetting priorities to 100 on each item: https://i.imgur.com/l62x2nY.png
    2. If that is done, then instead of exact matching, use the ‘AND with exact word matches’ logic: https://i.imgur.com/ccXoFt3.png
    3. Set the Index table relevance, so that the title is a very high value, and the term logic is the second highest, for example: https://i.imgur.com/UAVWwY6.png
    4. Set the ordering to ‘Title ascending’: https://i.imgur.com/WjV8mR1.png
    5. The blog category is properly excluded, as I can see in the options

    This will result in:
    Every search keyword must match exactly, either of the fields
    – and the title is far the most important field to match
    – the taxonomy terms are the second most important fields to match
    – and after matching the most relevant, order them by A-Z

    So the results will be chosen if all words match, if the title or the categories are matched, then those are prioritized (title higher, terms a bit lower), then ordered by title in ascending order.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14081
    Dezio
    Dezio
    Participant

    I changed anything you say but it don’t work cause there’s no priority.
    Examples: http://imgur.com/a/8kzCA

    Dezio

    #14089
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve checked the search instance configuration, everything was actually correctly configured there. I did some debugging and I found that the problem was with the Index table configuration. The content indexing was turned on, but you only needed titles, categories and tags: https://i.imgur.com/n5dUyEI.png

    I have turned off that option, and re-created the index table for you. Now it should return only relevant matches based on title or categories or tags, ordered ascending by post title.

    Examples:
    1: https://i.imgur.com/joYYLDc.png
    2: https://i.imgur.com/miGlFlW.png
    3: https://i.imgur.com/cG5ShPX.png

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #14117
    Dezio
    Dezio
    Participant

    That’s work but I lost the “botanical name” after the title name: http://imgur.com/a/8kzCA
    Is that on content maybe..

    #14130
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Sorry about that. I have disabled the content field by accident, when testing the solution. Now it should be visible again.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.