Problem with search in the search field

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Problem with search in the search field

This topic contains 13 replies, has 2 voices, and was last updated by Xpunto Xpunto 7 years, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #5044
    Xpunto
    Xpunto
    Participant

    Hello

    I have purchase that plugin yesterday at codecanyon, the problem is, i follow the steps in documantation also the plugin is installed.

    I have create a new search instance “test” <span class=”code”>enable suggested keywords</span>

    You can see that on my blog this is working but i can write no search term in the search box in the frontend of my homepage?

    In the backend the prieview test works if i try to search! Whats wrong?

    regards
    christian

    #5045
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It looks like something is forcing the form inside the search bar to 0 height.
    Try this custom CSS rule to fix the issue:

    
    .proinput form {
      height: 100% !important;
    }
    
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5046
    Xpunto
    Xpunto
    Participant

    Hi

    thank you for fast response, where i have to implement that code? I have child theme and custom css plugin installed.

    #5047
    Xpunto
    Xpunto
    Participant

    i paste that in the custom css but no change

    #5048
    Xpunto
    Xpunto
    Participant

    I can give admin details if you need!

    #5049
    Xpunto
    Xpunto
    Participant

    Look likes this problem is with that theme i try a other and there it works so you are right to 100% its the custom css rule.

    but if i paste that code in css custom

    .proinput form {
    height: 100% !important;
    }

    nothing happen?

    #5050
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I can’t see the rule on the page, maybe it’s still cached. Try to put it into the search plugin custom css: Theme Options -> Custom CSS panel

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5051
    Xpunto
    Xpunto
    Participant

    I found this code for the main search possible to change that to Ajax Pro?

    <?php
    /**
    * Search form template for product search.
    *
    *
    * @package Hamburg
    * @subpackage Templates/WooCommerce
    */

    /**
    * We’re counting search forms in order to
    * pass them unique ID values.
    *
    */
    $search_count = hamburg_counter( ‘search_form’ );
    ?>
    <div class=”site-search”>
    <div class=”search-form”>
    <form class=”inline-form” action=”<?php echo esc_url( home_url( ‘/’ ) ); ?>” role=”search”>
    <label for=”s_<?php echo $search_count; ?>”<?php
    /**
    * Look for search term.
    *
    * If the search field has a value, we pass an additional class
    * to its label which we positioned *behind* the transparent field.
    * Once the field gains focus or has a value we hide the label via CSS.
    * Why? Well, try styling a placeholder attribute, dude.
    *
    */
    if( ” !== get_search_query() )
    echo ‘ class=”has-value”‘;

    ?>>
    <span><?php echo _x( ‘Find products…’, ‘Search field label (ellipsis)’, ‘theme_hamburg_textdomain’ ); ?></span>
    <input id=”s_<?php echo $search_count; ?>” name=”s” type=”text” class=”search-input” value=”<?php echo esc_attr( get_search_query() ); ?>” />
    </label>
    <div class=”search-submit”>
    <input type=”submit” value=”<?php echo _x( ‘Submit’, ‘Search form submit button’, ‘theme_hamburg_textdomain’ ); ?>” />
    <input type=”hidden” name=”post_type” value=”product” />
    </div>
    </form>
    </div>
    </div>

    #5052
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I guess, maybe.

    Try to change the file contents to only the php search shortcode:

    <?php echo do_shortcode('[wpdreams_ajaxsearchpro id=1]'); ?>
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5053
    Xpunto
    Xpunto
    Participant

    Thank you i replace the code in the File ! the good think is its now in the header but search problem is not solved

    #5054
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Once again, try to put it into the Ajax Search Pro custom css field on the Theme Options -> Custom CSS panel: https://i.imgur.com/4IkwDzQ.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5055
    Xpunto
    Xpunto
    Participant

    I will 1000 Stars prefect support!!!!!! Now works!!!!!

    Sorry for my time i am not a coder just end product user all is clear i have not foud first the right place for that setting try custom css from theme not in the plugin settings!

    I have only 2 last questions

    First search speed is there any setting to do

    and second the result shows the author name i use moderator for puplic not the username what is in the moment in the search result is there a option to change that!

    THANK YOU!!!!! I will give full stars on codecanyon

    #5056
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you for the kind words!

    You can read about fine-tuning the search performance in the documentation here and here.

    There is currently no option to change that, but you can disable showing the author if you want to on the Layout Options -> Results layout panel, “Show author in results?” option.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5060
    Xpunto
    Xpunto
    Participant

    Thank you very much!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.