Question about formatting ajax search pro

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Question about formatting ajax search pro

This topic contains 3 replies, has 2 voices, and was last updated by

 
Keymaster
2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #24561

    Participant

    The plugin is installed and working well.

    One question: Is there a way to have 20 some categories show on the search page without having to use a scrolling device? When published on a page there is so much room there and I can’t find a way to spread out the categories like was done for the TV search custom fields. Is there a way to do this? I will include an image to explain.

    Thanks you.

    Tom

    Attachments:
    You must be logged in to view attached files.
    #24572

    Hi Tom,

    Currently there is no option for that. Someone recently asked a similar question, and I recommended a custom CSS solution, to display the categories next to one another. Try this:

    .asp_sb {
        max-width: none !important;
    }
    
    .asp_sb fieldset {
        flex: 1 1 0 !important;
    }
    
    .asp_sb fieldset.asp_filter_tax {
        flex: 10 1 auto !important;
    }
    
    .asp_filter_tax,
    .asp_filter_tax .asp_simplebar-content {
        display: flex !important;
        flex-wrap: wrap;
    }

    It should result in something like this: https://i.imgur.com/ZQRC8mg.png

    It is not the best possible solution, but it may as well work.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24593

    Participant

    Thank you! That works great! Perfect in fact.

    Preface – I am sure this is user error since when I create a new search instance, without any adjustments and using the regular search engine it works fine! But on the custom searches I get this:

    Now I just have to figure out what the checkboxes do. Sometimes when I check a checkbox it spins and the check disappears. Other times the search spins, it comes up with no posts even with the category selected. Then sometimes if I remove the checkmark it spins again and gives a different search result. When I check two categories and search on a term sometimes it comes with no results even though I know there are some posts in those categories using those terms. Am I making bad assumptions about what the checkboxes mean? Are there settings I have used that are throwing things off?

    Thanks so much

    Tom

    #24608

    Hi,

    It must be the checkbox logic. It is situational of course, but by default, the plugin displays results, when all of the checkboxes match from the given taxonomy.

    I suggest experimenting a bit with these options, to get the preferred results: https://i.imgur.com/jLeJf57.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.