Redirect URL issue

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29260
    isay.gonzalez56
    isay.gonzalez56
    Participant

    Hi and good morning.

    We have implemented the plugin in the site and then made all the configuration to allow the search bar in the index above another filter form that we have.
    The issue starts here: Our client wants to be redirected to the result page after click the Magnifier icon but, when i click the icon, the search url doesn’t show any result because the search URL needs the wp_nonce field for security reasons.
    I’ve checked the documentation to know how solve the issue but i do not found any information about it, so, is there any way to solve this issue for us?

    Here is an example of how the search URL looks with other search bar in the site:
    https://interbrokers.com.mx/?s=casas&wpestate_default_search_nonce=d305b30d8b&_wp_http_referer=%2F

    And this is how it look with the Redirect to: Results page selected options in Trigger and redirection behavior configuration: https://interbrokers.com.mx/?s=casas

    We use WP Residence WordPress Theme.

    Attachments:
    You must be logged in to view attached files.
    #29263
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    This knowledge base will help you with that. You can use that hook to add query arguments to the search before the it is printed to the page.
    Make sure that the results override feature is enabled for this.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.