Related Post Pro Is Not loading

Home Forums Product Support Forums Related Posts Pro for WordPress Support Related Post Pro Is Not loading

This topic contains 14 replies, has 2 voices, and was last updated by

 
Keymaster
6 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3925

    Participant

    Hello. Now posting in forum…

    The related posts are not loading, and when they do load they are all vertical regardless of the applied sizes in “Isonyc View” and “image size” in settings. I couldn’t add the URL because the site is unavailable now. Let me know if you have any other questions.

    Thanks!

    #3927

    Hi!

    This sounds like a javascript issue. Try to switch the javascript source under the “Compatibility Options” submenu from Minified scoped to minified.

    However if there is an error thrown from another javascript file coming from another plugin or theme, then this might not help.

    If you check the javascript console (F12 on most browsers) when reloading your page, it might show something – an error or warning perhaps.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4097

    Participant

    Hello. Thanks! The Related Posts are loading now, but they are all vertical instead of horizontal even after choosing “Fit Row” and reducing the width to a very small size.

    Thanks!

    #4105

    Well, it still might be a javascript or stylesheet conflict, I can’t tell without seeing it unfortunately.

    If you have any kind of test environment or any url to the content then I’m more than happy to check out.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4113

    Participant

    Hello.

    Ok. Below find the a link. Scroll to the bottom to see how all related posts are vertical even after choosing “Fit Row” and reducing the thumbnail sizes.

    https://christiansline.com/washingtons-bethany-community-church-gives-former-strip-club-a-holy-purpose/

    Thanks!

    #4114

    Hi!

    Thank you for the url. I see multiple issues in the header of the page:

    1. There is an error with one of the theme javascript files.
    2. There is an error coming from another module as well

    Screenshot of both of the errors on my error console: https://i.imgur.com/gQAukid.png
    There is a very high chance that these are the main causes, since the javascript program flow usually breaks after a fatal error or a warning is issues.
    I suggest investigating/fixing these issues first – because many wordpress plugins use jQuery (as well as Related Posts Pro), so they will most likely malfunction or not work at all.

    The errors does not indicate connection with the Related Posts Pro plugin, but you should of course try to deactivate the plugin first and check the error console to confirm this.

    The second and direct issue I can see is that some of the scripts (also CSS) in the header are printed incorrectly – there are some quote tags appended to the expressions. This can be related to any plugin or theme function that directly modifies the site or header data (like cache plugins and such).

    For example, if I take a look at the part of the related posts pro script declaration:

    
    " elementsAll ": " .rpp_item ",
    " visibleClass ": " rpp_visible ",
    " fadeoutClass ": " rpp_fadeout ",
    " titleSelector ": " .rpp_title ",
    

    The correct output should look like this:

    
    elementsAll: ".rpp_item",
    visibleClass : "rpp_visible",
    fadeoutClass : "rpp_fadeout",
    titleSelector : ".rpp_title",
    

    Somewhere, something adds extra space and a quote wrap around that script, which is a major issue. I have never seen anything similar, but I’m suspecting a 3rd party plugin – such as caching, minification or something very similar. It is also possible that this issue is related to the first ones.

    A general way of testing these issues is to turn off all the plugins and activate only Related Posts Pro first and see if it works then. If so, then activate the remaining plugins one by one to see at what point it fails again.

    If you want, you can also provide temporary access (login and ftp) and I can investigate this further. (you can do that by editing your first post in this thread) If so, then please do a full site and database backup, just in case.

    Let me know if anything helped!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4115

    Participant

    Hello.

    Thanks for the support! Actually, I also suspected it could be one of the caching mechanism we are using… W3 Total Cache, CloudFlare CDN/ Security, and Hide My WordPress which is a security plugin that changes the path of all files and folders to custom names, but also minifies website files. So before contacting you…

    1- We turned off W3 Total Cache plugin ‘minify”
    2- We turned off Cloudflare “Rocket Loader”
    3- We turned off all plugins, but didn’t try to reactivate them one by one because I thought the problem really might be with the caching plugins and CDN.

    So with your suggestions, let me try adding “Related Post Pro” to the exclusion list of “Hide My WordPress” to exclude it from custom path, and check all other plugins and see what I can find and get back with you.

    Thanks so much!

    #4124

    Participant

    Hello. We finally find out that Related Post Pro and Video Gallery For WordPress are conflicting with each other. Below you may find the link to that particular plugin. Now thinking about how to resolve this conflict because we need both plugins. 🙂

    http://codecanyon.net/item/video-gallery-wordpress-plugin-w-youtube-vimeo-/157782?WT.oss_phrase=gallery&WT.oss_rank=10&WT.z_author=ZoomIt&WT.ac=search_list

    Thanks!

    • This reply was modified 6 years, 10 months ago by  expresspubs.
    #4126

    Nice, at least we know where the problem is.

    However I can only offer very limited 3rd party support. I hope you understand, that authors simply can’t buy all the conflicting plugin combinations (there are like 1 million commercial, and another 2 million non commercial plugins available) just to test them. There is not enough time or money to do that.

    If you don’t want to provide details to your live server, you can still create a test or development environment with login and ftp access, where both plugins are active and conflicting, I’m more than happy to check that and fix it if possible.

    And, if none of this is possible, then probably the only solution I can see here is to add the correct script manually to one of the theme files, possibly the footer. I have grabbed the related posts pro script with the syntax errors from your site and corrected it. All you need to do now is to add this to the footer of your site. You will have to edit one of your theme files for this via FTP. In the active theme directory there should be a file called footer.php or something very similar. The active theme directory is usually wp-content/themes/{theme-name}/, you should look for that file there. On the very very bottom of that file there are usually these 2 lines present:

    
    </body>
    </html>
    

    These are the closing tags for the body and the html element. Above the closing body tag, add the following lines:

    
    <script type="text/javascript">
      rppjQuery(document).ready(function ($) {
        rppjQuery('div[id^="relatedpostspro_0_"]').relatedpostspro({
            "node": null,
            "elements": ".rpp_item.rpp_visible",
            "elementsAll": ".rpp_item",
            "visibleClass": "rpp_visible",
            "fadeoutClass": "rpp_fadeout",
            "titleSelector": ".rpp_title",
            "loadingSelector": ".rpp_cssloading_container",
            "relevanceSelector": ".rpp_relevance",
            "type": "isotope",
            "isotopeLayout": "fitRows",
            "transitionAnimation ": "fxFerris",
            "initialFilter": "post_type",
            "autoplay": true,
            "autoplayTime": "6000",
            "overrideFilter": true,
            "minShow":  8,
            "defSortValue": "rpp_relevance",
            "defSortOrder": "desc",
            "showSettings": 1,
            "showSearchByDefault": 0,
            "exactSearchMatchOnly": 1,
            "dots": true
        });
      });
    </script>
    

    This will add the declaration code statically, and the plugin should start working. The downside is, that this is a static code, so changing some of the settings on the plugin backend may not have effect here.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4127

    Participant

    Hello. Thanks! I fully understand that your support on a third party extension is limited and I really appreciate your help so far.

    At this point, I don’t think is a setting issue. I was able to correct the style or changes to style (color, font..etc) by switching on “Load inline stylesheets?” in “Compatibility Settings”. But I tried to use all the the settings under “Javascript Source” in “Compatibility Settings” and none of them solved the horizontal alignment issue.

    I think the temporary solution is to add the code you sent in the child theme to make it work for now. I will also notify the author of the Video Gallery. Sometimes authors take this reports into consideration when they are working on the next version of the plugin, so maybe this conflict might be taken into consideration and the conflict will be fix sooner or later.

    I will keep you updated after adding the script you sent.

    Thank you!

    #4128

    Participant

    Alright! The script you sent did worked. But it was another path… We use the same theme as you. 🙂

    wp-content/themes/x-child-integrity-light/framework/views/global/_footer.php

    Thanks!!!!

    #4137

    Participant

    Hello. What’s the latest version of “Related Post Pro”? We are using version 1.00 is that the current or latest version?

    Thanks!

    #4138

    Hi!

    1.00 is the latest.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4352

    Participant

    Hello. I bought Ajax Search Pro and having issue with customization… I activated the “Force Inline CSS” but still things like changing search button icon …etc are not being changed.

    I tried posting under Ajax Search Pro, but the purchase code is not being saved on your site. Please check below:

    For the item:
    Ajax Search Pro for WordPress – Live Search Plugin

    http://codecanyon.net/item/ajax-search-pro-for-wordpress-live-search-plugin/3357410
    Item ID: 3357410

    Item Purchase Code: 4e7ae532-6bb8-428d-a0e6-c5e5db07d2a8

    Purchase Date: 2015-03-28 04:17:09 UTC

    #4356

    Hi!

    If the changes are present after saving on the backend, then this is most likely a site cache issue.

    Make sure you clear the cache of all the caching plugins you have, and cloudflare as well (if you are using it). If it’s not helping, then you should provide temporary login details and an url where I can check this issue out.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.