Remove Results Page

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #33341
    bobdob50
    bobdob50
    Participant

    Hi. I don’t want a Results Page. I’ve looked everywhere in the knowledgebase, but nothing is working.

    My main focus has been ‘General Options’ and ‘Logic and Behavior’. [I’ve checked others as well.

    For “Action when clicking the magnifier icon” and Action when clicking the return button”, I have it set to ‘Do Nothing’. [I tried the other options as well.] It seems like this should work, but I keep getting redirected to a Results Page on my site. I just want the user to stay on the original search page and see the Results Box.

    Thank you

    #33351
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Do you mean you don’t want to get redirected when you click on one of the results, only display them?
    The Action when clicking the magnifier icon and return key options have no effect on that. You can however use a custom CSS to completely disable the click events on the results:

    .resdrg .item,
    .resdrg .item * {
        pointer-events: none;
    }

    This will disable the clicking on the results.

    Apply this code to your theme custom CSS field (if it supports it) or use the custom CSS field on the search plugin back-end.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33359
    bobdob50
    bobdob50
    Participant

    I’m sorry, I didn’t explain the problem properly.

    My problem is that when a user types in a search query into the input field, and either hits Return or Clicks on the Search Icon, I don’t want it to redirect to a Results Page. The Results Box (that automatically shows below the search box) captures what I want to display. Sending the visitor to another Results Page is redundant for me.

    When a user types in the query and hits Enter, I just want them to stay on the original page and interact with the Results Box instead of being redirected to a Results Page.

    Thank you.

    #33374
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Okay!

    In that case, if the “Do nothing” does not work, then try changing the return and magnifier actions to “Trigger live search” – it will basically do the same thing: https://i.imgur.com/32pqzaD.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.