Result problem

This topic contains 5 replies, has 2 voices, and was last updated by

 
Keymaster
5 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10108

    Participant

    Hello,

    I have a problem with some searches, can you have a look please :

    On the homepage :

    If you type “mc flu” or “mc flurr” there is no result but it’s supposed to have 1 result.
    The autocompletion is right and offer you the suggestion “mc flurry” but even if you type or click on “mc flurry” there is no results.

    If you type “flurry” there is a result.

    “mc flurry” is a post title

    Configuration :
    – Show exact match onfly : off
    – Keyworl logic : AND
    – Minimal character count to trigger search : 3
    – Cache : off
    – Search engine : index table engine
    – Index post title : yes
    – index post content /excerpt : off
    – Index post type : recipe.
    – Index taxonomies : ingredients

    Thank you for your help

    Attachments:
    You must be logged in to view attached files.
    #10110

    Hi,

    By default the index table engine does not consider words below 3 characters. I believe this is the problem here.

    1. Go to the index table options submenu and click on the Advanced options panel and turn off the Enable stop words option and set the Min. words length option to 0, then save the options: https://i.imgur.com/xemv4xe.png

    2. After saving, re-create the index table: https://i.imgur.com/FxmwRCE.png

    That should solve the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10111

    Participant

    Thank you for your very fast answer, the problem is solved 🙂

    Just an another question, the image used in the result are my big thumbnail post (https://www.cookomix.com/wp-content/uploads/2016/04/mc-flurry-thermomix.jpg)

    I didn’t see an option to specify a custom size for the_post_thumbnail (like medium, full, large etc… or a custom size defined in wordpress) i didn’t activate the image resizing in the plugin to save processor and because i have already the right size generated. There is a way to call programatically a custom size for the_post_thumbnail ?

    Thank you !

    Emmanuel

    #10124

    Hi!

    Well, there is no option for that yet (under construction).

    However there is a programatical way. Try putting this into the functions.php file in your active theme directory:

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10133

    Participant

    It’s perfect 🙂

    Thank you !

    #10145
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Result problem’ is closed to new replies.