Results are loading super slow.

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Results are loading super slow.

This topic contains 15 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #33531
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    With Caching = File enabled. We are using result Grouping enabled with Result limit as 2000.
    When we are searching for a word “time” its actually loading more than 1500 records. But the time to load all these LIVE results is 45 seconds.

    For surely, no one will visit my site, if my search results are getting displayed in 30-40 seconds

    Can you please suggest…what are the settings both in Plugin level, Application level Or, Server level we need to follow in order to make this plugin work faster.

    .
    Thanks

    #33538
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    It is very likely the results limit – 2000 is extremely high. WordPress needs to query all of their titles, contents, images and whatever fields needed. The search query itself is probably okay, it usually does not matter how many rows are queried on the database level. The issue in this case is more likely the post-processing – getting the result titles, fields etc.., which needs to be done via wordpress core.
    For the live results I would not recommend going anywhere over 50. Most wordpress archive pages show 10 results at the time by default for the same reason – querying thousands of items at the same time can be slow.
    Reducing the results limit below 50 should give you a very significant boost on the performance. Other than that, you can read up this knowledge base about performance improvements. However those target the main search query to be optimized as much as possible, but in your case I am almost certain, that the number of items queried at the same time is causing the bottleneck.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33544
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    Thanks for the information. I implemented it and restricted the results limit to 200 and yes, it does improves the performance, faster than yesterday.

    Now, one question, in our live site, the default wordpress search displaying more than 2000 records and its lighening fast. But after installing this plugin, if we are limiting to 2000, its becoming too slow to perform. Any specific reason to consider.

    Thanks

    #33546
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You may have some sort of a page cache or opcode/memcached cache active there. The plugin does not hook into the regular wordpress functionality – aside from checking on the search archive if it should override the search results with it’s own. It should not do that much harm though.

    If you want I can try debugging it via FTP by testing/correction the code parts line-by-line to see how the performance changes on the archive pages when the plugin is activated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33573
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    The site is an internal staging site and is firewall protected. so debugging through FTP won’t work out.

    Anyway. That part can be ignored now as at least we got some improved performance now.

    One more peculiar issue.
    When we type something on the Search box it displays a white box as LIVE SEARCH and an Ajax loader is there.

    Now 2 Scenarios –

    1) Scenario-1 >> With CLOSE ICON ENABLED in the Search Box –
    we type a word and the result got loaded in the result box. Now, we click on the close icon inside the Search box and typed SAME phrase again, the LIVE RESULTS page is deformed or, squeezed. see below.

    View post on imgur.com

    2) Scenario-2 >> With CLOSE ICON DISABLED in the Search Box –
    Now, if we type some word, then RESULT IS LOADED on the viewport and we pressed Backspace to remove the word or, phrase and type another word. Its Great working fine.

    Now, if we type something and the Loader is showing up and during that time I pressed the backspace button to delete the phrase, then the white RESULT WINDOW STILL REMAINS for INFINITY. see the image below.

    View post on imgur.com

    These 2 are VISIBLE Bugs.

    Thanks again for quick RESPONSE.

    #33598
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I’m not sure if I can tell only via screenshots I’m afraid. I can’t seem to be able to replicate this issue on any of our test servers, so I suspect that there might be a 3rd party asset (probably a script) involved creating this issue.

    If you place the search shortcode to a page content instead of the header and do the same test, does this issue persist?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33725
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    Sorry for late reply.

    Yes The issue persists even if I am trying that shortcode in a new blank page.

    Okay for the above mentioned Scenario-1 i:e;

    We type a word and the result got loaded in the result box. Now, we click on the close icon inside the Search box and typed SAME phrase again, the LIVE RESULTS page is deformed or, squeezed. see below.

    View post on imgur.com

    I tried the value 6vw instead of default auto for following settings.

    View post on imgur.com

    And I can see the issue is gone, but the results in the LIVE result window is now not aligned properly. But, the individual result height is affected because of this. SO thats make this issue, peculiar.

    View post on imgur.com

    So can you suggest best settings other than auto for “One result item height” so that it fits and the issue is resolved.

    Thanks

    • This reply was modified 1 year, 3 months ago by jsamal29 jsamal29.
    #33730
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Auto is the best setting, there is no better than that. Automatic height can not be achieved in any other way I’m afraid. You can try pixel heights as well, those are probable the second best, as that does not depend on the window height. Something like 70px or similar.

    Something else is very likely tempering with the styling or position of the container, if the auto height becomes effectively 0.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33754
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    This is the url of the copy of our application which can be publicly accessible as of now.

    https://devmotor.wpengine.com/

    Currently I have set the value as “auto”.

    For debugging, try to search the word “brake”, then click on close icon inside the search box. Then try again the same word. After 2-3 attempts, you can see the issue as mentioned earlier.

    Can you help to find any other settings or, custom css that can resolve the issue.

    Actually this is the last bug for which the whole project is on hold to be deployed to PROD.

    Thanks

    #33760
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you very much!

    It seem to be something with the default height setting on the results box, this custom CSS should resolve it for good:

    .asp_r .results {
        height: auto !important;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33762
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    This option also I tried earlier, but it extends the results container too long and the SCROLL bar disappears.

    I have updated the custom CSS, you can also check.

    https://devmotor.wpengine.com/

    Thanks

    • This reply was modified 1 year, 3 months ago by jsamal29 jsamal29.
    #33764
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Indeed. How about giving it a max-height relative to the window height:

    .asp_r .results {
        height: auto !important;
        max-height: 60vh !important;
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33765
    jsamal29
    jsamal29
    Participant

    Yipee…

    Yes that seems to fix the issue.

    I tried a lot of CSS options, but max-height also, maybe somewhere other element so it was of no use.

    Thanks again.

    But yes, for next release of plugin, please keep this in your bug list.

    • This reply was modified 1 year, 3 months ago by jsamal29 jsamal29.
    #33766
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Will take a closer look for sure, I still can’t see what the exact cause is though. I have exported your configuration, maybe something we can find there later.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34187
    jsamal29
    jsamal29
    Participant

    Hi Ernest,

    Thanks for all your support. The plugin is live now in our site.

    One peculiar issue I got, hope it will be a quick fix.

    In our site https://MOTOR.COM

    While searching for result oriented keyword….say—-“parts suppliers”, we get below screen which is normal. (we have Search Page header written – “SEARCH RESULTS”)

    View post on imgur.com

    While searching for keywords, which do not have results, that also appearing normal (see SEARCH RESULTS header at arrow pointed part in below image)

    View post on imgur.com

    BUT for a keyword, Interpretation or, Interp, the SEARCH RESULTS header part is disappearing from the results page. see arrow pointed part in below image.

    View post on imgur.com

    Thanks
    Jyoti

Viewing 15 posts - 1 through 15 (of 16 total)

The topic ‘Results are loading super slow.’ is closed to new replies.