Results Not Showing Below Search Settings

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Results Not Showing Below Search Settings

This topic contains 4 replies, has 2 voices, and was last updated by

 
Keymaster
1 year, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #28844

    Participant

    I know that this is something that I should be able to do and I cannot figure out why it isn’t working. I want a Search Form that:

    – will not have a search bar (no problem turning that off)
    – uses Categories and Taxonomy Terms with Checkboxes (this works just fine)
    – displays results as a grid (works great using the MaxUI Blue Isotopic Theme)
    – displays the results in a separate module (strongly preferred) or below the search settings/checkboxes (second choice)

    I tried:
    – [wd_asp elements='search,settings,results' ratio='100%,100%,100%' id=3] — the results still showed above the search settings
    – [wd_asp elements='settings,results' ratio='100%,100%' id=3] — module did not appear at all in this case
    – I tried separating the shortcodes and placing them in the desired order using the Code module in my theme (Divi)
    [wpdreams_asp_settings id=3 element='div']
    [wpdreams_ajaxsearchpro_results id=3 element='div'] — neither module appeared at all in this case

    Settings:
    – Results Layout Position is set to Block
    – Results Layout Type is set to Isotopic Results
    – shortcodes placed in Code Module in Divi Theme

    Error Messages: None

    • This topic was modified 1 year, 5 months ago by  sapientdaisy10. Reason: Incomplete entry
    • This topic was modified 1 year, 5 months ago by  sapientdaisy10.
    • This topic was modified 1 year, 5 months ago by  sapientdaisy10.
    Attachments:
    You must be logged in to view attached files.
    #28869

    Hi!

    Thank you for all the details, it helps a lot!

    Try this shortcode:

    [wd_asp elements='search,results' ratio='100%,100%' id=3]

    Since the search is actually turned off, the settings will replace the search module automatically.

    If you have any search widget visible on the same page, make sure to remove that as well. From the screenshot I suspect there is a search bar widget on the left side of the page – and in that case the shortcode above does not work, as the settings are already printed before the shortcode itself.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #28910

    Participant

    Hi there:

    Thanks very much for your reply. I’m definitely getting closer to my desired result but I’m not quite there yet. I’ll send you more details tomorrow after I play around with my settings a little more.

    I feel confident that we can get the results to show up in a new full width row below the search but now I am having trouble with their layout. I want them to show the Featured Image in a grid three across, without a scroll bar (much like a blog grid). I found this code (below) in the forum and it is close to working, but I can’t get the images to display correctly. I’m going to play around with that again in the morning but if you have any quick solutions, I’d really appreciate it!

    .resdrg .item {
    width: 33% !important;
    float: left !important;
    box-sizing: border-box !important;
    }

    Thanks!

    #28948

    Participant

    **SOLVED** I appreciated the hint that you gave me about having more than one search on the page and that it was probably causing the issue that I was having but I figured out a workaround that seems pretty OK. I’m adding this here in case it helps someone else.

    Settings:

    Layout Options > Search box layout > Hide the search… (OFF)

    Theme & Styling > Custom CSS >

    /**hide search bar**/

    div.asp_w.ajaxsearchpro.asp_non_compact {
    display: none;
    }

    Then on the page I created this structure:

    Code module for the search: [wd_asp elements='search,settings' ratio='0%,100%' id=7]

    Code module beneath it for results : [wd_asp elements='search,settings' ratio='0%,100%' id=7]

    #28965

    Thank you for letting us know! I will take a note of this thread, in case someone needs this setup.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.