Search box not displaying correctly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search box not displaying correctly

This topic contains 9 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 month, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #39871
    Nick Derington
    Nick Derington
    Participant

    Please see attachment. I am running search pro v4.23.3 on WP v6.1. The search box on my site works in Safari with no issue but I am having issues in both Chrome and Firefox displaying correctly. Please advise.

    #39875
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    If you are using SG optimizer by any chance, it has a bug, where it picks up some CSS files, but then it does not add it back in during the combine method. We already addressed that in the next release with a hacky workaround. I hope they will fix that soon, I see a lot of bypasses in other plugin codes as well just to get around this SG optimizer issue.

    Until then, you can resolve it by changing this option: https://i.imgur.com/46DQfwq.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39876
    Nick Derington
    Nick Derington
    Participant

    Thank you. So you are saying this will be address in your next update not SG Optimizer correct? I am currently using that.

    #39877
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Yes – we managed to find a way to get around this issue with the SG optimizer plugin, it will be included in the next release. They are also aware of the problem, hopefully they finally fix it too.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #40449
    Nick Derington
    Nick Derington
    Participant

    Hello –

    I just updated my Ajax Pro to Version 4.24.1 and I am having a similar issue as before. The live staging site at https://staging7.gracei13.sg-host.com/ appears to be unaffected but who I am inside my WP admin editing a page the header is having issues. Please see screen shot. Please advise. Thanks. FYI, I still have the fix in place that you recommended before. I have tried reverting that and it has no impact.

    Attachments:
    You must be logged in to view attached files.
    #40453
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Can you pelase add temporary back-end and FTP details? This issue seems unrelated to the previous, but when I try the same with Elementor back-end editor on our local servers it works all right.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #40461
    Nick Derington
    Nick Derington
    Participant
    You cannot access this content.
    #40466
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you!

    Turns out this was a known problem. We recently moved the asset folder for ajax search pro, and for some reason on sg-host staging environments the URL of the wp-content directory is reported with the non secure protocol “http://” instead of “https://”.
    It’s not a big deal, usually WordPress auto-corrects that at some point, but here it failed. I had to add a single line of code to force the correct protocol, now it should be fine.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #40474
    Nick Derington
    Nick Derington
    Participant

    Hi. Thank you. Fixed. Excellent customer services as usual.

    #40476
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Perfect, thank you, this fix will be included in the nex patch for sure.

    If you don’t mind, I will close this topic soon and mark it as resolved, feel free to open another one if you have other questions or issues.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.