Search by authors does not work correctly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search by authors does not work correctly

This topic contains 6 replies, has 2 voices, and was last updated by

 
Participant
1 year, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #29991

    Participant

    Search works selectively by authors …

    Wordpress search finds post author – http://joxi.ru/Vm6PYPjTvYLqGA ;
    Searching for the same query using your plugin – http://joxi.ru/12MqRqyFk9RQv2

    But at the same time, if, for example, look for another author. then finding your plugin works. That is, it cannot be due to incorrect settings, if it finds some, others do not. See example below. Authors are in the same user group.
    Алексей Шох – http://joxi.ru/Q2KNZNkivQZkym

    Standard search – https://huxley.media/?s
    Test page with Ajax Serach Pro plugin – https://huxley.media/develop/

    I need to set up a search by this principle. Is it possible? Sort by date and relevance for example. – ( Title – short description – article author – tag )

    #29993

    Hi,

    Can you please add temporary back-end and FTP details? I would like to check your configuration first. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29995

    Participant
    You cannot access this content.
    #30001

    Thank you!

    Actually, it is not correctly configured. The regular engine cannot find the posts by authors. The matches were probably due to a custom field, or there was a mention of the author in some text. To search the post author names, you will have to use the index table engine.
    Make sure to enable the index in post display names there, as well as to turn on the index table engine once it is ready.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30005

    Participant
    You cannot access this content.
    #30006

    Hi,

    I just checked your configuration, but the index table is still not configured, and not enabled either. Please follow the instructions in my previous ansnwer:

    To search the post author names, you will have to use the index table engine.
    Make sure to enable the index in post display names there, as well as to turn on the index table engine once it is ready.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30007

    Participant
    You cannot access this content.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.