Search doesn't work

This topic contains 8 replies, has 2 voices, and was last updated by Isidoros Rigas Eeriee 2 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #24654
    Isidoros Rigas
    Eeriee
    Participant

    Hello,

    I’ve purchased Ajax Search Pro, I’ve configured the form and I’ve placed it in the frontpage using Elementor but it doesn’t work when you click the search button. The weird thing is that it works when I preview it at the settings.

    I’ve tried debugging it but I couldn’t find anything wrong.

    Can you help me? I granted you admin access.

    Thanks!

    #24657
    Isidoros Rigas
    Eeriee
    Participant

    Tips:
    -try searching “targeted”
    -the form is in a pop-up called “Search”

    #24658
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you very much for the details, it helped a lot!

    The issue was, that the pop-up window was dynamically loaded, and the plugin was not able to initialize as the items were not existing on the page at the time of page load. I have enabed this option to fix this issue: https://i.imgur.com/GXrLkoC.png

    Now it should be working just like on the back-end.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24660
    Isidoros Rigas
    Eeriee
    Participant

    Nice! Thank you very much Ernest for your quick and effective answer!

    Ajax Search Pro is a bit expensive but it really is the best plugin for search. I’m going to leave a review on Codecanyon soon!

    #24661
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24670
    Isidoros Rigas
    Eeriee
    Participant

    Hi, immediately after I sent you the message it stopped working again on the frontpage. What should I look for?

    • This reply was modified 2 years, 10 months ago by Isidoros Rigas Eeriee.
    #24673
    Isidoros Rigas
    Eeriee
    Participant

    Also sometimes when you press Enter, it doesn’t load the results and instead it reloads the page.

    #24675
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I have tried multiple times, but it does work on my end. Can you please try clearing all layers of cache: browser, CDN, page cache, minify.
    Let me know if the issue persists.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24676
    Isidoros Rigas
    Eeriee
    Participant

    That’s weird. It doesn’t work when you are logged in, but it works when you aren’t. I’ll have to investigate it more.

    Thanks for your time Ernest!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.