Search is Broken

This topic contains 4 replies, has 2 voices, and was last updated by

6 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #3857


    After pushing from our staging to production site, the search function has stopped working.

    We also changed a few DNS settings so my assumption is that the file paths are just not working. I deactivated and reactivated the plugin and it does not seem to be working.

    My console logs are showing a 500 server error.

    Here is the full log:

     POST 500 (Internal Server Error)jquery.ajaxsearchpro.min.js?ver=4.1:2 sendjquery.ajaxsearchpro.min.js?ver=4.1:2 m.extend.ajaxjquery.ajaxsearchpro.min.js?ver=4.1:2 m.(anonymous function)jquery.ajaxsearchpro.min.js?ver=4.1:76 methods.searchjquery.ajaxsearchpro.min.js?ver=4.1:76 (anonymous function)jquery.ajaxsearchpro.min.js?ver=4.1:2 m.event.dispatchjquery.ajaxsearchpro.min.js?ver=4.1:2 r.handlejquery.ajaxsearchpro.min.js?ver=4.1:2 m.event.triggerjquery.ajaxsearchpro.min.js?ver=4.1:2 (anonymous function)jquery.ajaxsearchpro.min.js?ver=4.1:2 m.extend.eachjquery.ajaxsearchpro.min.js?ver=4.1:2 m.fn.m.eachjquery.ajaxsearchpro.min.js?ver=4.1:2 m.fn.extend.trigger(index):1363 (anonymous function)jquery.ajaxsearchpro.min.js?ver=4.1:2 m.event.dispatchjquery.ajaxsearchpro.min.js?ver=4.1:2 r.handle

    I also purged the cache to see if that would work. Any ideas on how to get this back up and working?

    • This topic was modified 6 years, 11 months ago by  grahamd711.


    The error message suggests that there is no ajax response due to a fatal error somewhere along the way. Turning on the error reporting in the wp-config.php might print something into the request.

    As long as the wordpress paths are correct the search paths should be correct as well. You haven’t changed the domain, so everything should be ok.
    Try to open op every settings page from the ajax search pro submenu and save them again. Maybe some of the options were lost along the way – I would say most likely the caching options.
    Also deactivating/activating the plugin sometimes helps.

    If nothing helps you can provide temporary ftp and amdin access and I can try to debug through the ajax handler to see where the error comes from.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    Thank you for the quick reply!

    I did try a the above methods and it is still not working. I do want to mention that I changed the domain as we went live on WPEngine hosting.


    I don’t know if that would have any effect. Since the staging url remained the same (and the search still works)..I assume it is an issue with the domain possibly changing file paths somewhere along the way.

    Any other ideas before I can send over admin creds? This is a production site so it is a bit concerning to be editing and testing lots of things while on the live site.

    Below is some more error logs:

    [Tue Feb 10 21:12:03 2015] [error] [client] PHP Fatal error: require_once() [function.require]: Failed opening required ‘/nas/wp/www/cluster-2209/liveintent/wp-content/plugins/ajax-search-pro//includes/imagecache.class.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /nas/wp/www/cluster-2209/liveintent/wp-content/plugins/ajax-search-pro/search.php on line 11, referer:

    I went to line 11 in search.php to find the below line…


    Looks like the error is being thrown because it cannot find the imagecache.class.php file?


    Yes, it means that file is missing. It probably wasn’t uploaded.

    Instead of uploading the ajax search directory, I recommend rather deactivating and deleting the plugin, then uploading it again. The settings table and the options will remain there. That should solve the problem instantly. You should save the settings again once uploaded, just to make sure that everything is consistent.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    Works now!

    For future reference, if anyone is using WPEngine for their WordPress hosting… and has this issue. You need do delete the plugin on both staging and production. Then install on production first, followed by staging. Assuming something was goofed when I deployed from staging –> production multiple times yesterday.

    Seems backwards but this was the only way I got it to work! Thanks for the help and super quick response, love the plugin.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.