Search Loading Speed Too Slow

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Loading Speed Too Slow

This topic contains 15 replies, has 2 voices, and was last updated by

 
Participant
5 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #8007

    Participant

    Hi

    I have some real speed issues with the search plugin, eventually there will be over 500 pages on the site that will be used for the search and I am concerned that when all these pages are live the search box will take even longer to show the results.

    With about 15 pages on the site it currently takes 15+ seconds to show the page list in the search drop down.

    I have configured some of the settings to speed up the search but its not helped that much

    Any advice would be great

    #8008

    Hi,

    The performance tracker reports that the search process finishes within 0.12 seconds in average. It means that there is either a hold-up process before or after the search, either due to an error or for some other reason. Unfortunately there are no error messages in the responses, so I can’t see why. It does not seem to be dependent on the configuration either, I have no idea what’s holding the response back.

    Can you also provide temporary FTP details so I can debug the full ajax request step-by-step? I might be able to uncover the exact line of code or plugin causing this insane delay.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8010

    Participant
    You cannot access this content.
    #8011

    Participant

    The site is in the policycentre.com folder

    #8013

    Hi,

    Thank you for the credentials. Can you please check the account permissions? I can only access an empty folder with the .ftpquota file in it.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8025

    Participant
    You cannot access this content.
    #8034

    Hi!

    I just tried the search again on the front-end and it’s working as normal. I’m getting results within 1-2 seconds.

    The back-end preview is not responding, but it might be related to the fact that it also sends some extra data back to the server.
    If you don’t mind, I would rather not start playing around debugging that, since it’s not the same as the one on the front-end. As long as the front-end is working correctly, there is nothing to worry about.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8074

    Participant

    Hi Ernest

    Thanks for your response, I am definitely not getting the same response times as you, I made a screencast video to show you the timing I am getting

    https://www.youtube.com/watch?v=dEsHpw1_rk4&feature=youtu.be

    Thanks

    #8075

    Hi,

    The video is set to private, I cannot watch it. Can you please change that?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8076

    Sorry, I’m able to see it now, I was logged in to the wrong channel.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8077

    Participant

    Hi sorry about that, you should now be able to see it

    Thanks

    #8078

    Hi,

    I was checking the other search bar, that’s why I was getting the wrong results.

    Also, I have found the source of the problem. After some stress testing I was able to reach the server resource limit. I will try to explain what happened when the response time was higher:
    I’m guessing you are on a shared hosting provider. They usually have a very strict limit for running processes, usually 10 or 20. Since the “Trigger search when typing?” option is enabled, the search starts after a low delay when the user starts typing – sending a request to the server. When the typing continues and the results didn’t arrive, the plugin tells the server to abort the previous request and deal with the new one, to save as much resource as possible. The autocomplete is a separate process, so it does similarly. So when typing for example “vacant” at a regular typing speed, the server recieved 4 + 6 requests when the final character “t” is reached. However if the resource limit is 10 and the first 9 processes were not aborted yet for some reason, this creates a huge delay – as the shared server must deal with other customers requests as well, running on the same server.
    This is how every (quality) ajax search plugin works, including google itself. (but they have an extremely powerful environment, so there is essentially no delay)
    Also, this explains why the performance tracker reported such fast speeds – the process itself was executed fast, but it was delayed.

    The solution
    Knowing this problem the best option is to minimize the request count to the server.
    1. I have disabled the “Trigger search when typing?” option. The search won’t start until the user presses enter. This will save huge amounts of server performance.
    2. I have yet disabled the autocomplete feature – but you should try testing it, maybe it does not affect the performance that much.
    3. I have configured the Index Table engine and enabled it for the top bar search. I recommend doing that for the rest of the search instances.

    Here is a video of the optimized search speed: https://www.youtube.com/watch?v=ZcDKiNd-jcQ

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8080

    Participant

    wow ok thank you for taking the time to explain this. I appreciate the advice and so will follow these guidelines and see how it runs

    Great plugin regardless of the issues so I will hop on to codecanyon and leave you a good review

    Thanks again for your time

    #8082

    Participant

    Sorry, I want to disable trigger search on the main search now as I think the top bar search on the site is perfect and fast but cannot seem to locate where to disable it in my other ajax search

    #8083

    Hi again!

    Sure thing: On the General Options -> Behavior panel, look for Trigger search when typing option.

    Don’t forget about the option search if you can’t find something, sometimes it helps: https://i.imgur.com/5BAPdRE.png
    I know there are confusingly many options. I’m working on a way to turn ON/OFF the least used ones for a basic configuration 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.