Search no working with normal posts

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search no working with normal posts

This topic contains 14 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 7 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #4478
    Pedro Carrillo
    Pedro Carrillo
    Participant

    The search results don´t work with normal posts. I´ve tried turning on the ajax handler as you told me and nothing happens. Also the option for Isotope theme is marked correct (send you sceenshot)
    Many thanks,

    Attachments:
    You must be logged in to view attached files.
    #4480
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thanks for the proper details! Could you please tell me where can I log in? The http://www.quiquealien.com/blog/wp-login.php and the http://www.quiquealien.com/blog/wp-admin/ urls are not working for me, I’m getting a redirect loop error. https://i.imgur.com/kBNxY40.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4484
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest!
    Both URLs work fine for me, I don´t understand what´s happening. I´ve checked in the server and there isn´t any blocks. Please try again and in case the problem persist, let me know.
    I have another concern, it´s about the portability of suggested keywords, seems not to be adapted to mobile.
    Thanks,

    #4487
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve tried on 5 proxy servers just now, to make sure it’s not my computer, but I still get the error message. Then I tried an US VPN service, but same error message. Perhaps there is an IP range block, or allowance? I’ve tried Gernam proxies, UK, US, Italian, but each is giving me the same error message. The site is working fine, it’s only the login.

    Could you explain more about the suggested keywords problem?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4488
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,
    I´ve sent a ticket to the server, I´ll let you know when I get an answer.
    About the problem with the portability of suggested words, it work ok in tablets, but no in smaller devices. T send you a sceershot from Iphone, but is the same problem in Android.

    Thanks,

    Attachments:
    You must be logged in to view attached files.
    #4490
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It’s not because of the plugin. The container, in which the search is placed on your site is 48% of width, and I see you changed it to ABSOLUTE position in the style.basic.css file. An absolute positioned element is removed from the document flow thus the keywords are floating over the page. Moreover the parent element is not set to relative position, so on higher resolution the search flies from the page as on my screen: https://i.imgur.com/SGsKNXn.png

    You need to set the slider element to a relative position:

    .home-slider {
        position: relative;
    }

    And change the absolute values to percents for the search:

    .asp_two_column {
      margin: 8px 0 12px 0;
      position: absolute;
      top: 15%;
      left: 4%;
    }

    So it will look like this on big screens: https://i.imgur.com/TpJsE2n.png
    And like this on mobile screens: https://i.imgur.com/1biNrks.png

    I can’t really provide support regarding customizations, but this is how I should do it 😉

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4492
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Thank you for the tip,

    Ok, the problem to access to wp-admin was a security role, it´s been sorted. Now you´ll need to enter first:
    Usuario: quondeir
    Contraseña: 6pCCj5o7S8OIkZm

    And then:
    User: Ajaxsearch Pass: codecanyon555555

    Thank you,

    #4493
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think I solved the problem.

    For some reason the Fulltext search was enabled. I’ve disabled it on the Fulltext Search Options submenu, now it should work correctly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4494
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,
    I appreciate your help, but it looks like this plugin is not suitable for my web.
    1. The search doesn´t work and after giving you the access the problem hasn´t been solved.
    2. The portability still not adecuate after editing the css as you told me (sreenshot) Also let me tell you that I understand you can not support customizations, but the only thing I´m trying is to implement exactly what you offer in your webpage, nothing else.
    3. The Javascripts is an aditional problem for Pagespeed, problem that I could bear if the other two problems did not happen.
    Thanks for your help and time but this plugin is just not for me. Never mind,
    Regards,

    #4495
    Pedro Carrillo
    Pedro Carrillo
    Participant

    I think we were writing at the same time.
    It works now, but the problem is the portability of both, the keywords and search results.
    For the search results it may improves changing the results area, i´ll try.

    Many thanks

    Attachments:
    You must be logged in to view attached files.
    #4498
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I further examined your page, and there is a solution you can use, made of simple CSS.

    1. You need to remove the section with the image: https://i.imgur.com/PN3n7Xp.png On the demo I’m not using an image element, but the image is a background to the section element. This is what you will need to do as well, and I will explain it how. Only remove the section, but don’t delete the image.

    2. Remove the absolute position and the top and left values in CSS of the search bar from the style.basic.css:

    .asp_two_column {
      margin: 8px 0 12px 0;
      /* position: absolute; */
      /* top: 34%; */
      /* left: 8%; */
    }

    so the page after should look like this: https://i.imgur.com/c5qmEaG.png

    3. Set the background of that section in CSS to the image you choose:

    section#text-116 {
      background-image: url(https://www.quiquealien.com/blog/wp-content/uploads/Portada-web.jpg);
      min-height: 548px;
      padding: 80px 40px 0;
      background-repeat: no-repeat;
    }

    It’s getting close to a solution. The page will now look like this: https://i.imgur.com/IWlBWaV.png

    4. With additional CSS make the two colums responsive:

    @media only screen and (max-width: 767px) {
        .asp_two_column_first,
        .asp_two_column_last {
            width: 100%;
            padding: 1% 0;
        }
    }

    This will stretch the search bar on devices below width of 768 pixels.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4499
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Just noticed, that the backround image on the previous post on the second CSS is incorrect, the code highlighter automatically changes it, it should be:

    background-image: url(https://www.quiquealien.com/blog/wp-content/uploads/Portada-web.jpg);
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4500
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Also if the search is not resizing, then try to add the !important tag to the query items:

    @media only screen and (max-width: 767px) {
        .asp_two_column_first,
        .asp_two_column_last {
            width: 100% !important;
            padding: 1% 0 !important;
        }
    }
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4501
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,

    Everything is perfect, fantastic plugin and fantastic suport, thank you very, very much.
    I´m at your disposition for whatever forum you want me to rate or comment about you or the plugin.

    Once again, many thanks.

    Best regards,

    #4502
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    You’re welcome! Thank you very much for the kind words!

    I think you can rate the plugin on your codecanyon downloads page: http://codecanyon.net/downloads

    Have a very nice weekend!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.