Search not filtering on 0-length searches

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search not filtering on 0-length searches

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32285
    tswagger74
    tswagger74
    Participant

    I have setup a few search bars with filters. These seem to work well with one exception. If I do a 0 length search, the filters are ignored and everything is returned. The filters work fine if I am search on something greater than 0 length.

    Under “General Options” -> “Logic and Behavior” I have set “Minimal character count to trigger search” to 0, as referenced in a few previous support posts.

    #32292
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for the details.

    I tried to visit the given URL, and it asked only for a password. I tried both passwords provided but they didn’t work. Can you pelase check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #32304
    tswagger74
    tswagger74
    Participant
    You cannot access this content.
    #32305
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you, that is working now.

    I tried the page “sermons”, changed the “content to” filter to 01/01/2020, and I am seeing 10 tag results and 10 post type results: https://i.imgur.com/ejfHUHt.png
    The first 10 results, which I marked with numbers on the screenshot are from taxonomy terms, those are not affected by the filters, as those are not post type results. You can turn those off on the General Options -> Sources 2 panel: https://i.imgur.com/ausuWOx.png
    I believe those are the ones you are reffering to when there is no phrase entered.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.