Search not showing relevant results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search not showing relevant results

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 2 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40300
    stylisticdesign
    stylisticdesign
    Participant

    Hi,

    So the main issue we’re having is that when we search for a term like “World War” the live results will show a mix of results, some with just war some with world, some with both, but we want the most relevant to appear at the top of the results. For example we have a post on our site titled “World War I” but when searching World War, this post seems to get mixed in somewhere else. I’ve also changed the relevance options making the title weight the highest and the other weights really low, hoping it would help but no luck.

    I am using the index table, with Primary logic with “AND with exact word matches” and Secondary logic disabled.

    Also tried using the Show exact matches only setting, which does work and will find results when searching for World War, but then if i just search for War no results will show. I also tried using allow secondary logic when exact matching, which does give more results, but the exact matched results get mixed in with the rest.

    So ideally i want the search to return the most relevant results based on the title which are the most exact matched results for the search term entered. If i search “World War” i want to see posts which titles contain World War, as a phrase, then onto the secondary logic results. Currently its not working, which it seems like it should.

    Hope that all makes sense.
    Thanks

    #40304
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you very much for all the details, it helps us a lot. This sounds like only a configuration issue, but I need to verify that.
    I tried to log-in, but the account does not have sufficient permissions to access the search settings. Can you please check that?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #40306
    stylisticdesign
    stylisticdesign
    Participant

    Should have given you full access now.

    #40325
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you!

    I found the issue. The result priorities are customized, and that includes the world war I and world war II articles as well: https://i.imgur.com/Jf49gu0.png
    Priorities override everything, even if the results have the highest relevance, they are automatically reordered based on priority values first. If you change them back to the default 100, it will resolve the problem.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #40342
    stylisticdesign
    stylisticdesign
    Participant

    Thank you!

    That has worked, getting more relevant results show up now. Funny how some were set so low, can’t remember changing the priorities and overlooked the Priorities settings, so thank you.

    #40344
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.