Search not working for long consecutive terms (more than 50 characters)

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search not working for long consecutive terms (more than 50 characters)

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 2 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28393
    streamer17
    streamer17
    Participant

    Hello,

    I bought Ajax search pro and I have the following problem. I have a post in wordpress called e.g. “Wunsch.und.Wirklichkeit.1998.German.DL.1080p.BluRay.AVC-ARMO”
    If a user searchs for the following term, everything is working fine:
    Wunsch und Wirklichkeit 1998 German DL 1080p BluRay AVC ARMO
    So if we remove all dots from the search term, we can search for the post and it will find it. If we search for “Wunsch.und.Wirklichkeit.1998.German.DL.1080p.BluRay.AVC-ARMO” (so term including the dots, which is the exact and original post name), it does not find the post anymore. It seems that if a term alone is longer than 50 characters, it is not working anymore. Somehow if there are dots instead of spaces between the words the search cant find the post if the post title is longer than 50 characters.

    How can we fix this? We can not replace the dots with spaces, as that would not be the correct post title anymore.

    Best regards

    #28411
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I assume you are using the index table engine? The table structure has a 50 character limit on single words for performance reasons.
    In this case, I would recommend switching back to the regular engine, or you can perhaps do an alter table query on the search database table, to allow longer words.
    For that, you will have to access the database via a tool, like PHPMyAdmin or similar, and run the following queries:

    ALTER TABLE wp_asp_index MODIFY COLUMN term VARCHAR(150) NOT NULL

    ..and

    ALTER TABLE wp_asp_index MODIFY COLUMN term_reverse VARCHAR(150) NOT NULL

    After the modification, you will have to re-create the index, so the data is populated again.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #28544
    streamer17
    streamer17
    Participant

    Hello,

    thank you for your help. The second option is working just fine!
    Now I noticed another problem though. I have a post titled
    “Ich.Und.Kaminski.2015.German.DTSHD.1080p.BluRay.AVC.REMUX-HDSource”

    If I search for “ich und kaminski” the post gets found. If I search for “kaminski” the post also gets found. If I search for “kaminski 1080p” or “kaminski bluray”, the post does not get found. “kaminski 2015” finds the post, but “kaminski 2015 german” does not anymore.
    There are some combinations that are working, while other combinations are not working although the terms are included in the title. Is there any fix to this? I can also provide you a link to the website itself if that would help.

    #28545
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Tough question, these should actually work, all of the combinations.
    May I ask how many keywords are there in the index table, and how many posts are there in the database (roughly)?

    Can you arrange back-end access to the site? That would help a lot. Thanks!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.