Search not working in Nav Bar

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search not working in Nav Bar

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 month, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #38281
    rochetommy
    rochetommy
    Participant

    Hi Ernest.
    Plugin working great throughout site (Compact Layout Mode) However, when I add it to the navigation menu it looks fine but clicking on the magnifier triggers a blank page with the following URL:

    about:blank#blocked

    I have tried all the recommended solutions for general troubleshooting but I cannot find any solution to my problem, so any help would be greatly appreciated.

    This may have nothing to do with the plugin itself and if that is the case I apologise in advance for taking up your time.

    PS I have removed the search from the navigation for now.

    Best wishes
    Tommy

    #38295
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for the details!

    I have logged in with the details to add the plugin to the main menu. However the account does not seem to have the privileges to acces the “widgets” and the “navigation menu” panels: https://i.imgur.com/or5hT0k.png
    Can you please check that?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #38300
    rochetommy
    rochetommy
    Participant

    Thanks for your prompt reply, Ernest.
    I’m using the WordPress Twenty Twenty-Two (child) theme which has Full Site Editing and doesn’t have widgets etc.

    To save you some time, I have inserted the shortcode into the Nav Menu so that you can see the problem I’m having. See cancerireland.ie

    Note, I previously changed the theme back to Twenty Twelve and inserted the shortcode directly into the menu (the old way – before Full Site Editing) but the results were exactly the same.

    To access the Nav Bar, please
    (a) click on Editor Beta (Image 01). This will take you to the Site Editor.
    (b) click on the Nav Bar border and a + sign appears (Image 2). Click on the + sign to Add New Block (image 3)
    (c) in the box that opens up, insert shortcode and click on submit (image 4)
    Click Save (top right of page) TWICE to save the settings.
    Now if you open cancerireland.ie in a new tab you should be able to see the problem.

    I hope I’m making myself clear.
    Best wishes,
    Tommy

    Attachments:
    You must be logged in to view attached files.
    #38318
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you, that was very helpful.

    Okay, so the issue was, that the menu item is inside an anchor tag, which has to have “href” attribute (where it points to), and in this case it was the shortcode name, which was not a valid URL.
    The only way I was able to trick the menu to think it is a menu link is, that I have changed the URL to “#search” – which is a non-existent anchor. Now when clicking, it updates the address bar to this anchor, but does not reload the page nor does anything else.
    Another option would be a custom code to simply disable the link, but this way no coding is required.

    I have also adjusted the search position to “absolute” from the default “static”, and changed the top and the right positions to match the menu bar.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #38320
    rochetommy
    rochetommy
    Participant

    Thank you so much Ernest. I am very happy with this. Boy, you really know your stuff!!!
    Thanks also for your fast response and comprehensive details. Awesome plugin and awesome support.
    Thank you once again.
    Tommy

    #38322
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.