Search priority / weighting not working on first load

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search priority / weighting not working on first load

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #39573
    melsaunders
    melsaunders
    Participant

    We have created a search on the site, but we would like the results to be weighted (e.g. the title should have priority over the description).

    https://booksfortopdev.wpengine.com/?s=history

    On first load results aren’t sorted by title, but after you check and uncheck a filter, the results will be sorted as they should (with correct weighting).

    The settings are done well in order to add relevance to the title, but are you able to advise how we can get it display like that on load?

    Thanks, Mel

    (I haven’t FTP, but can supply this if needed)

    #39581
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for the details!

    I tried to log-in, but the account does not have permission to view the settings. Anyways, I may not need it, I think I may know what the issue is. Can you please try this auto-populate configuration: https://i.imgur.com/CX9IGOo.png
    The other options force a custom ordering based on the criteria, this configuration will trigger the search without the override.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.